Typing a function name followed by enter no longer redirects to the function

RESOLVED FIXED

Status

Webtools
DXR
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: birtles, Assigned: erik)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(firefox41 affected)

Details

(Whiteboard: es)

(Reporter)

Description

3 years ago
STR:
1. Open http://dxr.allizom.org/
2. Type 'nsRefreshDriver::Tick' (without the single quotes)
3. Press Enter

Expected results:
Jumps to https://dxr.allizom.org/mozilla-central/source/layout/base/nsRefreshDriver.cpp?from=nsRefreshDriver::Tick#1571

Actual results:
Just goes to: https://dxr.allizom.org/mozilla-central/search?q=nsRefreshDriver%3A%3ATick&redirect=true

With the instance at https://dxr.mozilla.org/mozilla-central/ this works as expected.
(Assignee)

Updated

3 years ago
Blocks: 1127125
(Assignee)

Comment 1

3 years ago
This appears to be because we're storing only fully-qualified names ("nsRefreshDriver::Tick(int64_t, class mozilla::TimeStamp)") and not less qualified "scoped names", like nsRefreshDriver::Tick.
Assignee: nobody → erik

Comment 2

3 years ago
Commit pushed to es at https://github.com/mozilla/dxr

https://github.com/mozilla/dxr/commit/a1cd5198a1532deeb85d455cdc2f98a08660e044
Store type-stripped qualnames for functions as well, so we can search for Scoped::function rather than needing to say Scoped::function(int, char). Fixes bug 1171242.

We store them as a second item in function needles' qualname properties, which becomes a list. This causes the right thing to Just Happen in QualifiedNameFilterBase, which needed only a slight adjustment to tolerate qualnames that are lists.

Added an arg to some cases in test_functions, because we weren't testing that anywhere, and I don't trust future versions of clang to keep the "()" on the end of argless function qualnames.

Also, replace the keys kwarg of needles() with a simple include_qualname boolean. The desired keys don't seem to be expanding, and this way we don't have to repeat the names of the keys in the callers.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 3

2 years ago
Commit pushed to master at https://github.com/mozilla/dxr

https://github.com/mozilla/dxr/commit/a1cd5198a1532deeb85d455cdc2f98a08660e044
Store type-stripped qualnames for functions as well, so we can search for Scoped::function rather than needing to say Scoped::function(int, char). Fixes bug 1171242.
(Reporter)

Comment 4

2 years ago
Has this been deployed on dxr.mozilla.org yet?

I just tried the STR from comment 0 on dxr.mozilla.org and it failed to redirect.
Flags: needinfo?(erik)
(Reporter)

Updated

2 years ago
Flags: needinfo?(erik)
(Assignee)

Comment 5

2 years ago
It works for me. Still having trouble?
(Reporter)

Comment 6

2 years ago
Yes, works for me now! Thanks!
You need to log in before you can comment on or make changes to this bug.