nsLayoutModule.cpp:100:54: fatal error: mozilla/dom/FakeSpeechRecognitionService.h: No such file or directory when building with --disable-webspeech

RESOLVED DUPLICATE of bug 1171249

Status

()

defect
RESOLVED DUPLICATE of bug 1171249
4 years ago
4 years ago

People

(Reporter: stanl-mozilla, Assigned: kdavis)

Tracking

41 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150602154008

Steps to reproduce:

Pulled the latest version of nightly from hg.
Had to delete the build directory because of compiler change.
Compiled with ./mach build


Actual results:

11:41.99 In file included from /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-unknown-linux-gnu/layout/build/Unified_cpp_layout_build0.cpp:11:0:
11:42.00 /mnt/to_archive/accum/src/mozilla-central/layout/build/nsLayoutModule.cpp:100:54: fatal error: mozilla/dom/FakeSpeechRecognitionService.h: No such file or directory
11:42.00  #include "mozilla/dom/FakeSpeechRecognitionService.h"
11:42.00                                                       ^
11:42.00 compilation terminated.
11:43.77 
11:43.77 In the directory  /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-unknown-linux-gnu/layout/build
11:43.77 The following command failed to execute properly:
11:43.78 /bin/ccache c++ -o Unified_cpp_layout_build0.o -c -I../../dist/stl_wrappers -I../../dist/system_wrappers -include /mnt/to_archive/accum/src/mozilla-central/config/gcc_hidden.h -DOS_POSIX=1 -DOS_LINUX=1 -DSTATIC_EXPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DAB_CD=en-US -DNO_NSPR_10_SUPPORT -I/mnt/to_archive/accum/src/mozilla-central/layout/build -I. -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-unknown-linux-gnu/ipc/ipdl/_ipdlheaders -I/mnt/to_archive/accum/src/mozilla-central/ipc/chromium/src -I/mnt/to_archive/accum/src/mozilla-central/ipc/glue -I/mnt/to_archive/accum/src/mozilla-central/layout/build/../base -I/mnt/to_archive/accum/src/mozilla-central/layout/build/../forms -I/mnt/to_archive/accum/src/mozilla-central/layout/build/../generic -I/mnt/to_archive/accum/src/mozilla-central/layout/build/../inspector -I/mnt/to_archive/accum/src/mozilla-central/layout/build/../mathml -I/mnt/to_archive/accum/src/mozilla-central/layout/build/../style -I/mnt/to_archive/accum/src/mozilla-central/layout/build/../tables -I/mnt/to_archive/accum/src/mozilla-central/layout/build/../xul -I/mnt/to_archive/accum/src/mozilla-central/caps -I/mnt/to_archive/accum/src/mozilla-central/docshell/base -I/mnt/to_archive/accum/src/mozilla-central/dom/audiochannel -I/mnt/to_archive/accum/src/mozilla-central/dom/base -I/mnt/to_archive/accum/src/mozilla-central/dom/camera -I/mnt/to_archive/accum/src/mozilla-central/dom/canvas -I/mnt/to_archive/accum/src/mozilla-central/dom/filesystem -I/mnt/to_archive/accum/src/mozilla-central/dom/geolocation -I/mnt/to_archive/accum/src/mozilla-central/dom/html -I/mnt/to_archive/accum/src/mozilla-central/dom/json -I/mnt/to_archive/accum/src/mozilla-central/dom/jsurl -I/mnt/to_archive/accum/src/mozilla-central/dom/media -I/mnt/to_archive/accum/src/mozilla-central/dom/offline -I/mnt/to_archive/accum/src/mozilla-central/dom/speakermanager -I/mnt/to_archive/accum/src/mozilla-central/dom/storage -I/mnt/to_archive/accum/src/mozilla-central/dom/svg -I/mnt/to_archive/accum/src/mozilla-central/dom/telephony -I/mnt/to_archive/accum/src/mozilla-central/dom/xbl -I/mnt/to_archive/accum/src/mozilla-central/dom/xslt/base -I/mnt/to_archive/accum/src/mozilla-central/dom/xslt/xml -I/mnt/to_archive/accum/src/mozilla-central/dom/xslt/xpath -I/mnt/to_archive/accum/src/mozilla-central/dom/xslt/xslt -I/mnt/to_archive/accum/src/mozilla-central/dom/xul -I/mnt/to_archive/accum/src/mozilla-central/dom/xul/templates -I/mnt/to_archive/accum/src/mozilla-central/editor/composer -I/mnt/to_archive/accum/src/mozilla-central/editor/libeditor -I/mnt/to_archive/accum/src/mozilla-central/editor/txmgr -I/mnt/to_archive/accum/src/mozilla-central/editor/txtsvc -I/mnt/to_archive/accum/src/mozilla-central/extensions/cookie -I/mnt/to_archive/accum/src/mozilla-central/js/xpconnect/loader -I/mnt/to_archive/accum/src/mozilla-central/js/xpconnect/src -I/mnt/to_archive/accum/src/mozilla-central/netwerk/base -I/mnt/to_archive/accum/src/mozilla-central/netwerk/cookie -I/mnt/to_archive/accum/src/mozilla-central/view -I/mnt/to_archive/accum/src/mozilla-central/dom/secureelement -I../../dist/include -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-unknown-linux-gnu/dist/include/nspr -I/mnt/to_archive/accum/src/mozilla-central/obj-x86_64-unknown-linux-gnu/dist/include/nss -fPIC -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MP -MF .deps/Unified_cpp_layout_build0.o.pp -Wall -Wempty-body -Woverloaded-virtual -Wsign-compare -Wwrite-strings -Wno-invalid-offsetof -Wcast-align -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -pipe -DNDEBUG -DTRIMMED -g -O3 -fomit-frame-pointer -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/libxml2 /mnt/to_archive/accum/src/mozilla-central/obj-x86_64-unknown-linux-gnu/layout/build/Unified_cpp_layout_build0.cpp
11:43.78 /mnt/to_archive/accum/src/mozilla-central/config/rules.mk:946: recipe for target 'Unified_cpp_layout_build0.o' failed
11:43.78 gmake[5]: *** [Unified_cpp_layout_build0.o] Error 1
11:43.78 /mnt/to_archive/accum/src/mozilla-central/config/recurse.mk:71: recipe for target 'layout/build/target' failed
11:43.78 gmake[4]: *** [layout/build/target] Error 2
11:43.78 gmake[4]: *** Waiting for unfinished jobs....


Expected results:

firefox should have compiled.

The header file the build was looking for exists, in
./dom/media/webspeech/recognition/test/FakeSpeechRecognitionService.h
But I have webspeech turned off in my configuration.  I guess someone assumed it would always be on.  I realize that if I use a non-standard configuration, there is no guarantee it will work.  But this at least informs you that there is an issue.

I've attached the .mozconfig file I use.
Component: Untriaged → Build Config
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Component: Build Config → Web Speech
Product: Firefox → Core
Blocks: 1051146
Summary: hg pull of nightly on 20150603 fails to compile on Fedora 21 with custom config → nsLayoutModule.cpp:100:54: fatal error: mozilla/dom/FakeSpeechRecognitionService.h: No such file or directory when building with --disable-webspeech
Assignee: nobody → kdavis
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1171249
You need to log in before you can comment on or make changes to this bug.