[FFOS_2.2]There are 5 seconds black LCD display after boot animation

RESOLVED DUPLICATE of bug 1156141

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1156141
3 years ago
3 years ago

People

(Reporter: chencong, Assigned: sotaro)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11

Steps to reproduce:

1、 Used the tag code "AU_LINUX_GECKO_LF.BR.1.2.3.00.00.00.000.173" as the baseline code.
2、 Power on the phone.


Actual results:

There are 5 seconds black LCD display between the boot time from boot animation to init logo display.


Expected results:

There is on black LCD display during the boot time.
(Reporter)

Comment 1

3 years ago
Created attachment 8615132 [details]
VID_20150604_105630.zip.001
(Reporter)

Comment 2

3 years ago
Created attachment 8615133 [details]
VID_20150604_105630.zip.002
(Reporter)

Comment 3

3 years ago
Created attachment 8615134 [details]
VID_20150604_105630.zip.003
(Reporter)

Comment 4

3 years ago
Created attachment 8615136 [details]
VID_20150604_105630.zip.004
(Reporter)

Comment 5

3 years ago
Created attachment 8615137 [details]
VID_20150604_105630.zip.005
(Reporter)

Comment 6

3 years ago
There is one video about the boot.(Attached files VID_20150604_105630.zip.001 --  VID_20150604_105630.zip.005)
Flags: needinfo?(ryang)
(Reporter)

Comment 7

3 years ago
Hi shawn & Rachelle,

We find that this bug is relation with this commit
"commit 76bb3284b471187d8be5c618326546cd090ed2f2
Author: Sotaro Ikeda <sikeda@mozilla.com>
Date:   Tue May 12 06:32:00 2015 -0400

    Bug 1163681 - Fix fence handling. r=mwu, a=jocheng

 widget/gonk/libdisplay/GonkDisplayJB.cpp |   16 ++++++++++++----
 widget/gonk/libdisplay/GonkDisplayJB.h   |    1 -
 2 files changed, 12 insertions(+), 5 deletions(-)".
If we rollback the code of this commit, the black LCD issue can fix. But also the boot animation is  incoherent.
Hi Shawn, 

Would you please find someone to check this ?
Thank you !
Flags: needinfo?(ryang) → needinfo?(sku)
(Assignee)

Comment 9

3 years ago
I take a look.
Assignee: nobody → sotaro.ikeda.g
(Assignee)

Comment 10

3 years ago
From the investigation, Bug 1163681 seems not related. But 1156141 fixed the problem on v2.2 flame.
(Assignee)

Comment 11

3 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #10)
> From the investigation, Bug 1163681 seems not related. But 1156141 fixed the
> problem on v2.2 flame.

Bug 1156141
(Assignee)

Updated

3 years ago
blocking-b2g: --- → 2.2?
(Assignee)

Updated

3 years ago
Depends on: 1156141
(Assignee)

Comment 12

3 years ago
Set this bug as dup of bug 1156141 based on Comment 10. If it does not fix the problem, please reopen this bug.
blocking-b2g: 2.2? → ---
No longer depends on: 1156141
(Assignee)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1156141
(Reporter)

Comment 14

3 years ago
Hi Sotaro,

Yes, I merge the patch of bug 115614. It is fixed.
Thank you very much!

Updated

3 years ago
Flags: needinfo?(chenghuk)
You need to log in before you can comment on or make changes to this bug.