Closed Bug 1171358 Opened 4 years ago Closed 4 years ago

modules/libmar/tool/mar.c:416:10 [-Wunreachable-code-return] 'return' will never be executed

Categories

(Toolkit :: Application Update, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla41
Tracking Status
firefox41 --- fixed

People

(Reporter: cpeterson, Assigned: cpeterson)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This clang warning (not enabled by default) reports that the libmar tool's main() function never returns from the end of the function because the switch (argv[1][1]) statement above returns from every case and has a catch-all default case.

modules/libmar/tool/mar.c:416:10 [-Wunreachable-code-return] 'return' will never be executed
Attachment #8615172 - Flags: review?(robert.strong.bugs)
Attachment #8615172 - Flags: review?(robert.strong.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/0685087a4c4b
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
You need to log in before you can comment on or make changes to this bug.