Some requests from background tabs are visible in active tab

RESOLVED DUPLICATE of bug 1160837

Status

()

Firefox
Developer Tools: Netmonitor
RESOLVED DUPLICATE of bug 1160837
3 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8615191 [details]
Screenshot1

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

1. Open new window with only 1 tab in it - github.com
2. Open new tab
3. Open DevTools -> Network
4. Right-click the background tab and choose "reload page"



Actual results:

In the active tab you can see request to www.google-analytics.com (Tested on Win7)
This happens even with privacy.trackingprotection.enabled -> true. However, the request seems to be blocked if you reload github.com when that tab is active.
(Reporter)

Updated

3 years ago
Component: Untriaged → Developer Tools: Netmonitor
It's specifically about beacon requests and I'm working on it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1160837
(Reporter)

Updated

2 years ago
Has STR: --- → yes
You need to log in before you can comment on or make changes to this bug.