bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

filter editor replaces colors with rgb()

RESOLVED DUPLICATE of bug 1211796

Status

DevTools
Inspector
RESOLVED DUPLICATE of bug 1211796
3 years ago
a month ago

People

(Reporter: tromey, Assigned: tromey)

Tracking

Trunk

Firefox Tracking Flags

(firefox41 affected)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
If you have some CSS like

	filter: blur(1px) drop-shadow(16px 16px 20px blue);

and then use the filter editor to edit the color, the color
will be converted to rgb().

The color swatch editor, on the other hand, uses the current
"default color unit" (in my case, hex).
(Assignee)

Updated

3 years ago
Assignee: nobody → ttromey
Status: NEW → ASSIGNED
(Assignee)

Comment 1

3 years ago
Created attachment 8667471 [details] [diff] [review]
preserve authored text in filter editor
(Assignee)

Comment 2

3 years ago
I think the test changes rely on the as-authored series.
Depends on: 984880
(Assignee)

Updated

3 years ago
Attachment #8667471 - Flags: review?(mratcliffe)
Comment on attachment 8667471 [details] [diff] [review]
preserve authored text in filter editor

Review of attachment 8667471 [details] [diff] [review]:
-----------------------------------------------------------------

Awesome.
Attachment #8667471 - Flags: review?(mratcliffe) → review+
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1211796

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.