Closed Bug 1171613 Opened 4 years ago Closed 4 years ago

[Aries][Camera] Graphics are shown at wrong size, status bar is on screen

Categories

(Firefox OS Graveyard :: Gaia::Customizer, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5?)

RESOLVED FIXED
blocking-b2g 2.5?

People

(Reporter: amylee, Assigned: justindarc)

References

Details

(Whiteboard: [3.0-Daily-Testing][spark])

Attachments

(2 files)

Attached image IMG_20150604_144318.jpg
Description:
When you open the camera app, sometimes the status bar appears and the size of the focus ring is tiny and rotates on the wrong axis and then stays on the screen. The toggle switch icons are also very large. 

Repro Steps:

1. Open the camera app and then close it.
2. Restart the phone
2. Open the camera app and tap on the screen for touch focus.


Actual:
The size of the focus ring is tiny and rotates on the wrong axis and then stays on the screen. The camera/video toggle switch icons are also very large and the status bar is present on the screen. 

Expected:
The touch focus ring is at the correct size and rotation. Camera/Video toggle switch icons are correct size. The status bar is not present when the camera is opened.

Build ID               20150603172146
Gaia Revision          a99fd34784286efc935e07ddd55161d43950f673
Gaia Date              2015-06-03 16:32:24
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/196d99aabc27
Gecko Version          41.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150603.170707
Firmware Date          Wed Jun  3 17:07:15 UTC 2015
Bootloader             s1
Summary: [Aries][Camera] → [Aries][Camera] Graphics are shown at wrong size, status bar is on screen
[Blocking Requested - why for this release]:
blocking-b2g: --- → spark?
Diego, can you see if you can reproduce this?
Flags: needinfo?(dmarcos)
Duplicate of this bug: 1172940
Attached file pull-request (master)
This patch fixes all our styles so they are only applied locally except for explicit cases where we need to inject global styles (e.g. body padding/scrolling, loading @font-face).
Assignee: nobody → jdarcangelo
Flags: needinfo?(dmarcos)
Attachment #8620604 - Flags: review?(drs)
Comment on attachment 8620604 [details] [review]
pull-request (master)

Looks good. I left a couple of comments on the PR.
Attachment #8620604 - Flags: review?(drs) → review+
Landed on master:

https://github.com/fxos/customizer/commit/2cb124072d30a2620780fb0790a756c1c56976cf
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Component: Gaia::Camera → Gaia::Customizer
blocking-b2g: spark? → 2.5?
You need to log in before you can comment on or make changes to this bug.