Long pressing the power button- "Phone" shows at top of menu

VERIFIED FIXED

Status

Firefox OS
Gaia
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: marcia, Assigned: wilsonpage)

Tracking

({polish})

unspecified
ARM
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(blocking-b2g:-, b2g-v2.2 affected, b2g-master verified)

Details

(Whiteboard: [spark] [foxfoodUX])

Attachments

(3 attachments)

Created attachment 8615655 [details]
2015-06-04-15-23-21.png

Seen on Flame as well, not sure what the purpose of showing "Phone" is - see attached screenshot.

Flame build:
Gaia-Rev        85e6fcef45c0cb2c017739df42b68b96cf5bb9c3
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/666b584fb521
Build-ID        20150601075320
Version         41.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150601.112750
FW-Date         Mon Jun  1 11:28:01 EDT 2015
Bootloader      L1TC000118D0


STR:
1. Long press the power button
2. Observe the attached screenshot.
Can UX take a look here?
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 2

3 years ago
What is the component in question here? I can assign it if I know, but right now this is just "Gaia".
Whiteboard: [spark] → [spark] [foxfoodUX]
We should drop the header in this case. It doesn't make a lot of sense in this context.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(anygregor)
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Duplicate of this bug: 1196269
[Blocking Requested - why for this release]: this is carried over from duplicated bug 1196269 comment 4.
blocking-b2g: --- → 2.5?

Comment 6

3 years ago
[Triage] Not a blocker. However, we'd still like to have UX/UI's feedback.
blocking-b2g: 2.5? → -
Flags: needinfo?(firefoxos-ux-bugzilla)
Keywords: polish
Created attachment 8651676 [details] [review]
[gaia] wilsonpage:1171734 > mozilla-b2g:master
(Assignee)

Updated

3 years ago
Assignee: nobody → wilsonpage
(Assignee)

Comment 8

3 years ago
Comment on attachment 8651676 [details] [review]
[gaia] wilsonpage:1171734 > mozilla-b2g:master

This patch drops the 'Phone' header as suggested in comment 3.
Attachment #8651676 - Flags: review?(gmarty)
(Assignee)

Comment 9

3 years ago
The duplicate of this bug was marked as blocking 2.5 [1] 

[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1196269#c4
(Assignee)

Comment 10

3 years ago
Comment on attachment 8651676 [details] [review]
[gaia] wilsonpage:1171734 > mozilla-b2g:master

Just updated to remove styling and tests. Funilly enough there is actually a test to assert that the text 'Phone' is present [1].

Also switching review to Alberto after discussing with Gmarty.

https://github.com/mozilla-b2g/gaia/blob/master/tests/python/gaia-ui-tests/gaiatest/tests/functional/system/test_power_button_long_press.py#L23
Attachment #8651676 - Flags: review?(gmarty) → review?(apastor)
Comment on attachment 8651676 [details] [review]
[gaia] wilsonpage:1171734 > mozilla-b2g:master

The code looks good to me! Let's wait for the tests before landing though. Thanks!
Attachment #8651676 - Flags: review?(apastor) → review+
I'm not sure why UX was NI'd again as Rob's comment 3 addressed the question and Wilson seems to have a patch. Do we need someone from UX to review the patch?

Thanks for pinging the UX team!
Flags: needinfo?(atsai)

Comment 13

3 years ago
I assume that's for UX to clarify the status. According to comment 3, we should remove the title or rephrase it. However, there's no action item being decided and I believe UX should be the correct caller. That's the reason I ni? UX team. I'd like to know if we have a better way for it. There's no concerns from me to merge it to master and close the bug as resolved fixed. 

For some reasons, UX team responses ni? slowly. I prefer to keep it here and UX team can have a status update with the patch we have. If there's no concerns for UX consistency, please feel free to clear the ni flag.
Flags: needinfo?(atsai)
Hey Al - I think there might be some confusion, both Rob (comment 3) and I are both on the UX team :)

Unfortunately, we are super understaffed so we aren't going to be able to come up with fresh designs for 2.5. So I think for now, doing as Rob's suggests in comment 3 is going to be the best and easiest for 2.5.

Being understaffed is also why we are slow to respond to NI's. We lost Steph awhile ago and now we only triage ux ni flags once per week. 

Thanks for your patience and understanding!
Flags: needinfo?(firefoxos-ux-bugzilla)
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: Long pressing the power button, it doesn't show "Phone" at top of menu.
See attachment: verified_Flame_v2.5.png
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150929150202
Gaia Revision          f345f6a015709beeb2ca3955cab077fcaa959d3b
Gaia Date              2015-09-29 03:53:51
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ccee6614fd9d18a31f263fbcfe9676b224d851aa
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150929.201052
Firmware Date          Tue Sep 29 20:11:01 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20150930005445
Gaia Revision          1bc0b19527777ffee494962b48db4be857b07d64
Gaia Date              2015-09-29 20:01:07
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/891ee0d0ba3ec42b6484cf0205b3c95e21c58f74
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150930.001258
Firmware Date          Wed Sep 30 00:13:06 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-master: affected → verified
Created attachment 8667677 [details]
verified_Flame_v2.5.png
Flags: needinfo?(anygregor)
You need to log in before you can comment on or make changes to this bug.