Closed Bug 1171783 Opened 5 years ago Closed 5 years ago

bootstrap.py: yum is deprecated on Fedora 22

Categories

(Firefox Build System :: General, defect)

All
Linux
defect
Not set

Tracking

(firefox41 affected, firefox43 fixed)

RESOLVED FIXED
mozilla43
Tracking Status
firefox41 --- affected
firefox43 --- fixed

People

(Reporter: WeirdAl, Assigned: aaronraimist)

References

Details

Attachments

(1 file, 1 obsolete file)

Executing as root: yum install autoconf213 mercurial
Yum command has been deprecated, redirecting to '/usr/bin/dnf install autoconf213 mercurial'.

and so on, and so forth...
OS: Unspecified → Linux
Hardware: Unspecified → All
Attached patch bug1171783_yumToDnfBootstrap (obsolete) — Splinter Review
This should work. I have only tested on Fedora 22. Someone will need to try it out on CentOS and maybe older versions of Fedora.
Assignee: nobody → aaronraimist
Status: NEW → ASSIGNED
Attachment #8621919 - Flags: review?(mshal)
Comment on attachment 8621919 [details] [diff] [review]
bug1171783_yumToDnfBootstrap

>-    def yum_install(self, *packages):
>-        command = ['yum', 'install']
>+    def dnf_install(self, *packages):
>+        if self.which('dnf'):
>+          command = ['dnf', 'install']

Please use a 4-space indent to be consistent with the rest of the file.

I tested this with an older fedora (19) and it seems to work fine with yum. My centos VM has a way too old python to be useful, though.
Attachment #8621919 - Flags: review?(mshal) → feedback+
Attachment #8621919 - Attachment is obsolete: true
Attachment #8624447 - Flags: review?(mshal)
Comment on attachment 8624447 [details] [diff] [review]
bug1171783_yumToDnfBootstrap

Thanks!
Attachment #8624447 - Flags: review?(mshal) → review+
Just ran into this too, anything stopping it from being landed?
Flags: needinfo?(aaronraimist)
Probably not. Just a reviewed patch that fell through the cracks. I really wish Bugzilla could alert for these things...

I'll land this now, provided it still applies cleanly.
Flags: needinfo?(aaronraimist)
https://hg.mozilla.org/mozilla-central/rev/1a22056aa274
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Duplicate of this bug: 972157
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.