User can not revert the settings once the background colour and text colour are same

RESOLVED WORKSFORME

Status

()

Firefox
Preferences
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: Kapil, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

65.76 KB, image/jpeg
Details
(Reporter)

Description

3 years ago
Created attachment 8615861 [details]
Bug.JPG

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36

Steps to reproduce:

Step1. Open the Firefox and go to Options-->Content and change the background colour and text colour to white (In general to same colour)
Step 2. Open the browser again and now user wants to get default setting for background and text colours so go to Options-->Content


Actual results:

Step1. The colour of the background and text are changed successfully
Step2. User is not able to see anything except some of the check boxes and dropdowns. There is no way that user can change the text and background colour

I have uninstalled the Mozilla and reinstall  it again but still the user faces the same problem of not seeing anything on the page so user can not change the setting for colours of Background and text 

Because of this problem the Mozilla becomes unusable on that box which is a serious issue


Expected results:

The expectation is that either the changing of the background colour and text colour to same colour should be stopped or once we uninstall and reinstall mozilla it should take us to the default settings

Comment 1

3 years ago
Second option is not possible because reinstalling Firefox without deleting the profile doesn't remove the modifications you did previously to your profile. You need to delete the profile when uninstalling Firefox.

Anyway, you can reset it to fix issues with prefs, it's faster.
https://support.mozilla.org/en-US/kb/reset-firefox-to-fix-most-problems
Component: Untriaged → Preferences
We could add a simple check that they are not the exact same color, but if the two colors are very close (#ffffff vs. #fffffe) for example, then that check will fail but it will still be equally unusable.

I'm not sure what we can do here, besides introduce a color contrast algorithm and either block or provide an override when there isn't enough contrast.

I think the other route would be to force the preferences to disregard the color preferences altogether, though that may cause issues with accessibility.
(Reporter)

Comment 3

3 years ago
(In reply to Loic from comment #1)
> Second option is not possible because reinstalling Firefox without deleting
> the profile doesn't remove the modifications you did previously to your
> profile. You need to delete the profile when uninstalling Firefox.
> 
> Anyway, you can reset it to fix issues with prefs, it's faster.
> https://support.mozilla.org/en-US/kb/reset-firefox-to-fix-most-problems

Refreshing the firefox from troubleshoot worked 

Thanks
Marking as Resolved WFM (based on comment 3).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.