put shortcuts for backward/forward in menu

VERIFIED FIXED in seamonkey1.0alpha

Status

P4
normal
VERIFIED FIXED
17 years ago
11 years ago

People

(Reporter: jo.hermans, Assigned: mano)

Tracking

({helpwanted, platform-parity})

Trunk
seamonkey1.0alpha
PowerPC
Mac OS X
helpwanted, platform-parity

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
build 2001122106 (regular 0.9.7) on MacOS 9.2.2

The 'Go' menu has items for backward and forward navigation, but their shortcuts
are missing in the Modern and Classic skin :

- cmd-[ (or cmd-left arrow)
- cmd-] (or cmd-right arrow)
Status: UNCONFIRMED → NEW
Ever confirmed: true
i don't have a mac build in front of me, but... kathy, on linux the Go menu
lists "Alt+Left Arrow", etc. is the Go menu on mac still lacking those labels? i
couldn't find an existing bug, but if it's a known issue, this bug should prolly
be marked a dup of it.
Assignee: aaronl → brade
Summary: put shortcuts for backward/foreward in menubar → put shortcuts for backward/foreward in menu

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: pp

Updated

17 years ago
Summary: put shortcuts for backward/foreward in menu → put shortcuts for backward/forward in menu
Target Milestone: --- → mozilla0.9.9

Comment 2

17 years ago
balancing milestones
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 4

17 years ago
Moving Netscape owned 0.9.9 and 1.0 bugs that don't have an nsbeta1, nsbeta1+,
topembed, topembed+, Mozilla0.9.9+ or Mozilla1.0+ keyword.  Please send any
questions or feedback about this to adt@netscape.com.  You can search for
"Moving bugs not scheduled for a project" to quickly delete this bugmail.
Target Milestone: mozilla1.0 → mozilla1.2

Updated

17 years ago
Keywords: helpwanted
Target Milestone: mozilla1.2alpha → Future

Comment 5

17 years ago
ALT-left/right arrows do not work on Linux.

I am using i386 Linux
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020615 Debian/1.0.0-3

In the Go menu, it is written that back/forward page is ALT-left/right arrow. 
However, on my system these keys do not do anything.  (I always use ALT instead
of CTRL, see
user_pref("ui.key.accelKey", 18);user_pref("ui.key.menuAccessKey", 0);
as written at http://www.mozilla.org/releases/mozilla1.0/)

For information, I have just tried ALT-[ and ALT-] and they really go
forward/backward page.

In fact, I have been noticing this since a few months ago.
(Reporter)

Comment 6

16 years ago
The shortcuts are still missing in build 2003032908 (almost 1.4a) on Mac OS X
10.2.4, so I changed the OS-field of this bug.
OS: Mac System 9.x → MacOS X
(Reporter)

Comment 7

16 years ago
*** Bug 188089 has been marked as a duplicate of this bug. ***
On mac, the right keybindings to show are Accel+[ / ]
Created attachment 171507 [details] [diff] [review]
patch

see last comment.
Assignee: brade → bugs.mano
Attachment #171507 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #171507 - Flags: review?(brade)
Severity: trivial → normal
Priority: -- → P4
Target Milestone: Future → mozilla1.8beta

Updated

14 years ago
Attachment #171507 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+
Attachment #171507 - Flags: review?(brade) → review?(jhpedemonte)
Attachment #171507 - Flags: review?(jhpedemonte)
Attachment #171507 - Flags: review+
Checked in to trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Component: Keyboard: Navigation → XP Apps: GUI Features
Product: Core → Mozilla Application Suite
Target Milestone: mozilla1.8beta1 → Seamonkey1.0alpha

Updated

11 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.