Audio is not in sync with Video

RESOLVED DUPLICATE of bug 1168040

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1168040
3 years ago
2 years ago

People

(Reporter: stefan.greffenius, Unassigned)

Tracking

({regression})

37 Branch
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.95 Safari/537.36

Steps to reproduce:

We have 2 videos, the original and an 360p encoded one from the original. The original makes not problems. For the encoded one the audio gets out of sync with the video.

Testet in native firefox player.

Firefox 35.0.1 working
Firefox 36.0 working
Firefox 37.0 NOT working

Here are the 2 video files:

---

Original:

http://videos.sofatutor.com/uploads/168830f0d575fd59221c986dc10394a7/original/168830f0d575fd59221c986dc10394a7.mp4?AWSAccessKeyId=AKIAIYNS4L4ATJKTRIHQ&Expires=1441282931&Signature=P2OLekmRgNlA5KpyIreqvJbgtCU%3D

Media info:

General
Format : MPEG-4
Codec ID : M4V 
File size : 311 MiB
Duration : 6mn 54s
Overall bit rate mode : Variable
Overall bit rate : 6 298 Kbps
Encoded date : UTC 2014-05-27 07:48:30
Tagged date : UTC 2014-05-27 07:48:36
©TIM : 00:00:00:00
©TSC : 25
©TSZ : 1

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.2
Format settings, CABAC : No
Format settings, ReFrames : 2 frames
Format settings, GOP : M=1, N=75
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 6mn 54s
Bit rate mode : Variable
Bit rate : 6 104 Kbps
Maximum bit rate : 7 500 Kbps
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 25.000 fps
Standard : PAL
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.118
Stream size : 301 MiB (97%)
Language : English
Encoded date : UTC 2014-05-27 07:48:30
Tagged date : UTC 2014-05-27 07:48:30
Color primaries : BT.709
Transfer characteristics : BT.709
Matrix coefficients : BT.709

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 40
Duration : 6mn 54s
Source duration : 6mn 54s
Bit rate mode : Variable
Bit rate : 192 Kbps
Maximum bit rate : 258 Kbps
Channel count : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Compression mode : Lossy
Stream size : 9.35 MiB (3%)
Source stream size : 9.35 MiB (3%)
Language : English

---

360p encoded one

http://videos.sofatutor.com/uploads/168830f0d575fd59221c986dc10394a7/full-360-mp4/10a3433031b350430b702ebfe788bd03.mp4?AWSAccessKeyId=AKIAIYNS4L4ATJKTRIHQ&Expires=1441283166&Signature=e5025Hq6wY2P5Uh2NmsBlLlelmw%3D

Media info:

General
Format : MPEG-4
Format profile : Base Media
Codec ID : isom
File size : 40.6 MiB
Duration : 6mn 54s
Overall bit rate mode : Variable
Overall bit rate : 822 Kbps
Writing application : Lavf53.0.0

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L3.0
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 6mn 54s
Bit rate : 750 Kbps
Width : 640 pixels
Height : 360 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 25.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.130
Stream size : 37.0 MiB (91%)
Writing library : x264 core 115 r1937 aa21558
Encoding settings : cabac=1 / ref=4 / deblock=1:0:0 / analyse=0x3:0x113 / me=umh / subme=8 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=0 / weightp=2 / keyint=25 / keyint_min=13 / scenecut=40 / intra_refresh=0 / rc_lookahead=25 / rc=2pass / mbtree=1 / bitrate=750 / ratetol=1.0 / qcomp=0.60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.41 / aq=1:1.00
Language : English

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 40
Duration : 6mn 54s
Bit rate mode : Variable
Bit rate : 68.6 Kbps
Maximum bit rate : 128 Kbps
Channel count : 2 channels
Channel positions : Front: L R
Sampling rate : 44.1 KHz
Compression mode : Lossy
Stream size : 3.39 MiB (8%)
Language : English

Both video links are valid for 90days. 
If they need to be extended or if i can help in any other way please let me know.


Actual results:

When watching the 360p encoded one the audio gets out of sync after 40 seconds. The audio playback jumps 60 seconds forward. Audio and video are out of sync.


Expected results:

Audio and video should be in sync all the time.

Comment 1

3 years ago
Can you try to find the regression range?
mozregression --good-release 36 --bad-release 37
http://mozilla.github.io/mozregression/

Does this also happen in the latest Nightly in a brand new profile?
https://nightly.mozilla.org
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles

Type about:support into the location bar, then press Enter. Click the “Copy text to clipboard” button. Paste the clipboard contents in a comment here.
Component: Untriaged → Video/Audio
Flags: needinfo?(stefan.greffenius)
Keywords: regressionwindow-wanted
Product: Firefox → Core
(Reporter)

Comment 2

3 years ago
It is working in Nightly with brand new profile and even with the default one.

Then i reinstalled Firefox 37 and he tooked the new profile it was also working! When switching back to default profile it stopped working for me.

about:support of Firefox 37.0 with default profile:

Allgemeine Informationen
------------------------

Name: Firefox
Version: 37.0
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Fenster mit mehreren Prozessen: 0/1

Absturzberichte der letzten 3 Tage
----------------------------------

Alle Absturzberichte

Erweiterungen
-------------

Grafik
------

Direct2D aktiviert: true
DirectWrite aktiviert: true (6.2.9200.16571)
Geräte-ID: 0x0166
GPU #2 aktiv: false
GPU-beschleunigte Fenster: 1/1 Direct3D 11 (OMTC)
Karten-Beschreibung: Intel(R) HD Graphics 4000
Karten-RAM: Unknown
Karten-Treiber: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Subsys-ID: 500217aa
Treiber-Datum: 6-6-2012
Treiber-Version: 8.15.10.2778
Vendor-ID: 0x8086
WebGL-Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

Wichtige modifizierte Einstellungen
-----------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 1
browser.places.smartBookmarksVersion: 7
browser.privatebrowsing.autostart: true
browser.startup.homepage: http://www.sofatutor.com/
browser.startup.homepage_override.buildID: 20150615030204
browser.startup.homepage_override.mstone: ignore
dom.apps.reset-permissions: true
dom.mozApps.used: true
dom.w3c_touch_events.expose: false
extensions.lastAppVersion: 37.0
gfx.direct3d.last_used_feature_level_idx: 0
gfx.direct3d.prefer_10_1: true
gfx.driver-init.appVersion: 41.0a1
gfx.driver-init.deviceID: 0x0166
gfx.driver-init.driverVersion: 8.15.10.2778
gfx.driver-init.feature-d2d: true
gfx.driver-init.feature-d3d11: true
gfx.driver-init.status: 2
media.gmp-eme-adobe.lastUpdate: 1433414782
media.gmp-eme-adobe.version: 10
media.gmp-gmpopenh264.lastUpdate: 1434379121
media.gmp-gmpopenh264.version: 1.4
media.gmp-manager.buildID: 20150615030204
media.gmp-manager.lastCheck: 1434379120
network.cookie.prefsMigrated: true
network.http.atsvc.enabled: false
network.http.atsvc.oe: false
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1434379142
places.history.expiration.transient_current_max_pages: 95878
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
print.printer_sofaprinter_Admin.print_bgcolor: false
print.printer_sofaprinter_Admin.print_bgimages: false
print.printer_sofaprinter_Admin.print_colorspace:
print.printer_sofaprinter_Admin.print_command:
print.printer_sofaprinter_Admin.print_downloadfonts: false
print.printer_sofaprinter_Admin.print_duplex: 1515870810
print.printer_sofaprinter_Admin.print_edge_bottom: 0
print.printer_sofaprinter_Admin.print_edge_left: 0
print.printer_sofaprinter_Admin.print_edge_right: 0
print.printer_sofaprinter_Admin.print_edge_top: 0
print.printer_sofaprinter_Admin.print_evenpages: true
print.printer_sofaprinter_Admin.print_footercenter:
print.printer_sofaprinter_Admin.print_footerleft: &PT
print.printer_sofaprinter_Admin.print_footerright: &D
print.printer_sofaprinter_Admin.print_headercenter:
print.printer_sofaprinter_Admin.print_headerleft: &T
print.printer_sofaprinter_Admin.print_headerright: &U
print.printer_sofaprinter_Admin.print_in_color: true
print.printer_sofaprinter_Admin.print_margin_bottom: 0.5
print.printer_sofaprinter_Admin.print_margin_left: 0.5
print.printer_sofaprinter_Admin.print_margin_right: 0.5
print.printer_sofaprinter_Admin.print_margin_top: 0.5
print.printer_sofaprinter_Admin.print_oddpages: true
print.printer_sofaprinter_Admin.print_orientation: 0
print.printer_sofaprinter_Admin.print_page_delay: 50
print.printer_sofaprinter_Admin.print_paper_data: 9
print.printer_sofaprinter_Admin.print_paper_height: 11,00
print.printer_sofaprinter_Admin.print_paper_name:
print.printer_sofaprinter_Admin.print_paper_size_type: 0
print.printer_sofaprinter_Admin.print_paper_size_unit: 1
print.printer_sofaprinter_Admin.print_paper_width: 8,50
print.printer_sofaprinter_Admin.print_plex_name:
print.printer_sofaprinter_Admin.print_resolution: 1515870810
print.printer_sofaprinter_Admin.print_resolution_name:
print.printer_sofaprinter_Admin.print_reversed: false
print.printer_sofaprinter_Admin.print_scaling: 1,00
print.printer_sofaprinter_Admin.print_shrink_to_fit: true
print.printer_sofaprinter_Admin.print_to_file: false
print.printer_sofaprinter_Admin.print_unwriteable_margin_bottom: 0
print.printer_sofaprinter_Admin.print_unwriteable_margin_left: 0
print.printer_sofaprinter_Admin.print_unwriteable_margin_right: 0
print.printer_sofaprinter_Admin.print_unwriteable_margin_top: 0
privacy.cpd.offlineApps: true
privacy.cpd.siteSettings: true
privacy.sanitize.migrateFx3Prefs: true
security.sandbox.content.tempDirSuffix: {f3867749-f3e8-40bf-bac3-6a4fe6438310}
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1432644698

Wichtige nicht veränderbare Einstellungen
-----------------------------------------

browser.startup.homepage_override.mstone: ignore
privacy.donottrackheader.enabled: true

JavaScript
----------

Inkrementelle GC: true

Barrierefreiheit
----------------

Aktiviert: false
Barrierefreiheit verhindern: 0

Bibliotheken-Versionen
----------------------

NSPR
Minimal vorausgesetzte Version: 4.10.8
Verwendete Version: 4.10.8

NSS
Minimal vorausgesetzte Version: 3.17.4 Basic ECC
Verwendete Version: 3.17.4 Basic ECC

NSSSMIME
Minimal vorausgesetzte Version: 3.17.4 Basic ECC
Verwendete Version: 3.17.4 Basic ECC

NSSSSL
Minimal vorausgesetzte Version: 3.17.4 Basic ECC
Verwendete Version: 3.17.4 Basic ECC

NSSUTIL
Minimal vorausgesetzte Version: 3.17.4
Verwendete Version: 3.17.4

Experimentelle Funktionen
-------------------------
Flags: needinfo?(stefan.greffenius)
(Reporter)

Comment 3

3 years ago
mozregression --good-release 36 --bad-release 37

...
25:42.09 LOG: MainThread Bisector INFO Oh noes, no (more) inbound revisions :(
25:42.09 LOG: MainThread Bisector INFO Last good revision: 332fa08016f8
25:42.09 LOG: MainThread Bisector INFO First bad revision: ccdda35627df
25:42.09 LOG: MainThread Bisector INFO Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=332fa0
8016f8&tochange=ccdda35627df
(Reporter)

Comment 4

3 years ago
Since the last mozregression was not realy promissing, i tried:

mozregression --good 2015-03-03 --bad 2015-03-26

I went from bad releases to a good one, here the result:

Was this nightly build good, bad, or broken? (type 'good', 'bad', 'skip', 'retry
', 'back' or 'exit' and press Enter): good
10:38.72 LOG: MainThread Bisector INFO Narrowed nightly regression window from [
2015-03-03, 2015-03-05] (2 days) to [2015-03-04, 2015-03-05] (1 days) (~0 steps
left)
10:38.72 LOG: MainThread Bisector INFO Got as far as we can go bisecting nightli
es...
10:38.72 LOG: MainThread Bisector INFO Last good revision: c5b90c003be8
10:38.72 LOG: MainThread Bisector INFO First bad revision: 993eb76a8bd6
10:38.72 LOG: MainThread Bisector INFO Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c5b90c003be8&tocha
nge=993eb76a8bd6

Comment 5

3 years ago
(In reply to stefan.greffenius from comment #4)
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c5b90c003be8&tochange=993eb76a8bd6

Thank you for the update. Unfortunately, there are multiple patches having to do with video, and I can't tell which one may have regressed this.

(In reply to stefan.greffenius from comment #2)
> It is working in Nightly with brand new profile and even with the default
> one.
> 
> Then i reinstalled Firefox 37 and he tooked the new profile it was also
> working! When switching back to default profile it stopped working for me.

That suggests that Nightly modifies a preference that fixes the issue. You can test this theory by starting Firefox in a brand new profile, exiting, then copying the prefs.js file from the Nightly profile over the one in the brand new profile for Release.
If Release then works when started in that profile, you could try to find which preference is the relevant one by doing a comparison of the two prefs.js files (using a text editor like Notepad++).
Keywords: regressionwindow-wanted → regression
(Reporter)

Comment 6

3 years ago
Hey Gingerbread Man, sorry for late response had a lot todo. You are right, i used a brand new nightly profile in firefox 37 and it worked! Here is the diff between both prefs.js files.

https://www.diffchecker.com/nf1nyv34
(its stored for one month)

The left one is the Firefox 37 default profile which doesn't work. And right one is the working nightly profile.

Since there are so many changes in the diff i couldn't test every single line. Is the diff enough for you? Or can you give me a hint which lines could be importend to test?
(Reporter)

Comment 7

3 years ago
Ahh sorry forget to mention, i copied the nightly prefs.js to the default firefox profile. I was not just using the nightly profile.

Comment 8

3 years ago
(In reply to stefan.greffenius from comment #2)
> Karten-Beschreibung: Intel(R) HD Graphics 4000
> Treiber-Datum: 6-6-2012

Your graphics drivers are very old. Please try updating them and testing again. If your computer manufacturer doesn't offer more recent drivers, see the ones from Intel:
https://downloadcenter.intel.com/search?keyword=HD+Graphics+4000

(In reply to stefan.greffenius from comment #6)
> Is the diff enough for you? Or can you give me a hint which lines
> could be importend to test?

Thank you for the update.

If updating your graphics drivers doesn't help, try this:
1. Paste the following into the location bar, then press Enter.
about:config?filter=media.hardware-video-decoding.failed
2. Click the “I'll be careful, I promise!” button to bypass the warning.
3. If there's a preference by that name listed in the search results, make sure it's set to true (double-click it to toggle its value). If there's no preference by that name, right-click somewhere in the lower pane and choose New, then Boolean. As the preference name, enter media.hardware-video-decoding.failed and as the value, enter true
4. In the search box, paste the following.
gfx.direct3d.prefer_10_1
5. In the search results, right-click gfx.direct3d.prefer_10_1 and choose Reset.
6. Restart Firefox.
(Reporter)

Comment 9

3 years ago
I had trouble updating the drivers. I tried also your link but i always ended up with a canceld setup by intel because of this behavior:

A customized computer manufacturer driver is installed on your computer. The Intel Driver Update Utility is not able to update the driver. Installing a generic Intel driver instead of the customized computer manufacturer driver may cause technical issues. Contact your computer manufacturer for the latest driver for your computer.

Then i did your steps 1-3 without issues. But when i searched for gfx.direct3d.prefer_10_1 (step 4) he founds nothing. So i couldn't reset gfx.direct3d.prefer_10_1. When i searched for gfx.direct3d he only finds gfx.direct3d.last_used_feature_level_idx not sure if there should be more?

Then i restarted the browser and had still the error.
(Reporter)

Comment 10

2 years ago
How to proceed with this bug? Is there anything i can assist with?
This sounds like it could be a duplicate of bug 1168040, which was fixed in Firefox 41 (currently beta).
(Reporter)

Comment 12

2 years ago
I can confirm its working with Firefox 41.0b5, thanks!

Comment 13

2 years ago
Thank you for the update. It seems safe to mark this as a duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1168040
You need to log in before you can comment on or make changes to this bug.