Closed Bug 1171938 Opened 4 years ago Closed 4 years ago

mouseevent over google map div in firefox 39.0 shows incorrect coordinates

Categories

(Firefox :: Untriaged, defect)

39 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1175863
Tracking Status
firefox39 --- affected
firefox40 --- affected
firefox41 --- affected

People

(Reporter: steen95, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.81 Safari/537.36

Steps to reproduce:

A page with google map div does not return the correct coordinates from the mouse event in firefox when the map div is not at the top left (0,0) of the browser window. If I put any css padding or margin on the map div, the mouseevent origin in google maps still starts from the top left of the browser window and not the map div.  See example at http://jsfiddle.net/fNPvf/15426/.  This worked correctly at v38.0.5.


Actual results:

mouseevent coordinates are incorrect over padded div
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2b9f5019abf1&tochange=4100738d662d

Triggered by: 43b9c8451378	Robert O'Callahan — Bug 69787. Implement MouseEvent.offsetX/Y. r=mats,smaug

The following UA spoofing helps:

user_pref("general.useragent.override", "Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.65 Safari/537.36");


Should be TE bug
Blocks: 69787
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(roc)
OK, we already have a bug related to this on file with Google.
Flags: needinfo?(roc)
Can we dupe this to 1175863?
Duplicate of this bug: 1182139
Duplicate of this bug: 1182431
What's the evolution of this bug from Mozilla and GG sides? Some dupes are surfacing on BMO with the FF39 release.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1175863
You need to log in before you can comment on or make changes to this bug.