FireFox 37.0.1 running on OS X 10.10.3 will not authenticate against proxy server

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: ted.carr.corp, Unassigned)

Tracking

37 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

I have setup FF to use our corporate proxy server via both "Automated proxy config URL:" or "Manual proxy config".  


Actual results:

FF will prompt me for authentication to the proxy.  Once credentials are entered I click on "OK" and FF returns a page that says "The proxy server is refusing connections".  I have worked with the department in charge of our "WebSense" proxy server and they tell me that they never see the authentication from my browser, however they do see the proxy requests...
I have tried setting "network.negotiate-auth.trusted-uris" and "network.automatic-ntlm-auth.trusted-uris" to our AD domain to no avail.
This was not an issue in previous versions of FF, but I only use FF intermittently on my Mac, so I am not 100% sure when it stopped working.


Expected results:

I should be surfing the net...
(Reporter)

Comment 1

3 years ago
Quick Update: I just noticed that the page I have set as my home page uses HTTPS ... If I try and go to an HTTP site then I am directed to an error page from the proxy server that says: "You must be authenticated to access this URL."  There is also another message that reads "Last Executed Rule: Authenticate Against Active Directory Using NTLM Protocol".
(Reporter)

Comment 2

3 years ago
Apologies all ... A little more Googling found my answer: network.auth.force-generic-ntlm-v1 = true fixed my issue.
OS: Unspecified → Mac OS X
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.