If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Link to "customize search providers" when user presses search label in quick search bar

RESOLVED FIXED in Firefox 44

Status

()

Firefox for Android
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: antlam, Assigned: tynn, Mentored)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 44
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 verified, relnote-firefox 44+)

Details

(Whiteboard: [lang=java])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

2 years ago
As per bug 1172071

Sizing for the button's hit area is 48dp x 48dp.
I offered Anthony the alternative approach to have this search button run the default search - it gives users a clearer indication of what the search bar is supposed to do than jumping into settings (e.g. do all the buttons jump into settings?). We can try out Anthony's approach and see how it goes because it's better from a power user perspective.
Depends on: 1172071
(Reporter)

Comment 2

2 years ago
As a follow up to the visual hint, how hard would it be to link to this page in settings Sebastian?
Flags: needinfo?(s.kaspari)
(In reply to Anthony Lam (:antlam) from comment #2)
> As a follow up to the visual hint, how hard would it be to link to this page
> in settings Sebastian?

I'm not sure just yet. But it shouldn't be impossible. To be honest I wonder if this is something even power users need. Do power users actually change their search engines "all the time"? Nevertheless we can try it. If we decide to have the button do something else then we can always have this as an option on long press.
Flags: needinfo?(s.kaspari)
Duplicate of this bug: 1209929
This could be mentorable. The tricky part is making sure that this works with all different setting layouts.
Mentor: michael.l.comella@gmail.com, s.kaspari@gmail.com
Whiteboard: [lang=java]
The place to start here would be SearchEngineBar (which is where the magnifying glass icon is shown). GeckoPreferences is where our preference code starts and where you may be able to find the Search settings path.
via IRC.
Assignee: nobody → tynn.dev
(Assignee)

Comment 8

2 years ago
Created attachment 8674300 [details] [diff] [review]
bug1172083.patch

Starting "preferences_search" with a click on the magnifying glass.
Attachment #8674300 - Flags: review?(michael.l.comella)
Comment on attachment 8674300 [details] [diff] [review]
bug1172083.patch

Review of attachment 8674300 [details] [diff] [review]:
-----------------------------------------------------------------

Nice! Works well!

However, the pressed state isn't shown when I click the label, as when I click other labels – can you look into adding that?
Attachment #8674300 - Flags: review?(michael.l.comella) → review+
(Assignee)

Comment 10

2 years ago
Created attachment 8674544 [details] [diff] [review]
bug1172083.patch

Ohh, I didn't see any press state for the favicons, so I thought this was intentional. Added the background to the label as well.
Attachment #8674300 - Attachment is obsolete: true
Attachment #8674544 - Flags: review?(michael.l.comella)
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c38cbf257bac
Blocks: 1215750
Comment on attachment 8674544 [details] [diff] [review]
bug1172083.patch

Review of attachment 8674544 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me! Thanks Christian!

By the way, I filed bug 1215750 to add Telemetry to this button - it's waiting on Anthony to know if it's necessary. You could follow along, or even take the bug yourself! :)
Attachment #8674544 - Flags: review?(michael.l.comella) → review+
(Assignee)

Comment 13

2 years ago
Android 4.3 API11+ opt M(rc4) failed after a retry. How can I rerun this test?

(In reply to Michael Comella (:mcomella) from comment #12)
> By the way, I filed bug 1215750 to add Telemetry to this button - it's
> waiting on Anthony to know if it's necessary. You could follow along, or
> even take the bug yourself! :)

I'd like to take the bug myself after this one is landed.
Flags: needinfo?(michael.l.comella)

Comment 14

2 years ago
(In reply to Christian Schmitz (:tynn) from comment #13)
> Android 4.3 API11+ opt M(rc4) failed after a retry. How can I rerun this
> test?

I believe you need special permissions for that. I just retriggered the job for you, but it looks like it's not your fault.

> (In reply to Michael Comella (:mcomella) from comment #12)
> > By the way, I filed bug 1215750 to add Telemetry to this button - it's
> > waiting on Anthony to know if it's necessary. You could follow along, or
> > even take the bug yourself! :)
> 
> I'd like to take the bug myself after this one is landed.

I'll assign you!
Flags: needinfo?(michael.l.comella)

Updated

2 years ago
Keywords: checkin-needed
(Assignee)

Comment 15

2 years ago
Thank you Margaret.

Comment 16

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/688d6e1caaca
Keywords: checkin-needed

Comment 17

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/688d6e1caaca
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox44: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 44
Tested using:
Build: Firefox 44.0a1 (2015-10-27)
Device: Prestigio PSP5508 (Android 4.4.2)

Tapping the magnifying glass from the quick search bar opens the search submenu from settings.
But "Nightly" is displayed as a header: http://i.imgur.com/k6xF7H1.png
Is this expected?

Maybe it should be "Search". The same when you go to Menu -> Settings -> Customize -> Search:  http://i.imgur.com/AeM2Egc.png
status-firefox44: fixed → verified

Comment 19

2 years ago
(In reply to Teodora Vermesan (:TeoVermesan) from comment #18)
> Tested using:
> Build: Firefox 44.0a1 (2015-10-27)
> Device: Prestigio PSP5508 (Android 4.4.2)
> 
> Tapping the magnifying glass from the quick search bar opens the search
> submenu from settings.
> But "Nightly" is displayed as a header: http://i.imgur.com/k6xF7H1.png
> Is this expected?
> 
> Maybe it should be "Search". The same when you go to Menu -> Settings ->
> Customize -> Search:  http://i.imgur.com/AeM2Egc.png

I think we should file a new bug to address this. Christian, are you interested in filing a new bug and investigating this?
Flags: needinfo?(tynn.dev)
(Reporter)

Comment 20

2 years ago
I think it says "Nightly" because it returns to Fennec when you press it (hardware back or this back button). 

Though the label should say "<-- Search", the current UX flow is the desired one here. So let's be sure we're just updating the visual. :)
(Assignee)

Updated

2 years ago
See Also: → bug 1219416
(Assignee)

Updated

2 years ago
Flags: needinfo?(tynn.dev)

Updated

2 years ago
Depends on: 1219416
See Also: bug 1219416
Margaret, do we want a relnote for this?
relnote-firefox: --- → ?
Flags: needinfo?(margaret.leibovic)

Comment 22

2 years ago
(In reply to Michael Comella (:mcomella) from comment #21)
> Margaret, do we want a relnote for this?

Sure, this could fit in well with the search history suggestions.
Flags: needinfo?(margaret.leibovic)
Blocks: 1221163
Michael, Margaret, could you please provide suggested wording and blog/MDN links for this to be added to Beta44 release notes? Thanks.
Flags: needinfo?(michael.l.comella)
Flags: needinfo?(margaret.leibovic)
(In reply to Ritu Kothari (:ritu) from comment #23)
> Michael, Margaret, could you please provide suggested wording and blog/MDN
> links for this to be added to Beta44 release notes? Thanks.

Spoke on irc – I think the title of this bug ("Link to "customize search providers" when user presses search label in quick search bar") seems appropriate.
Flags: needinfo?(michael.l.comella)
Added to Beta44 release notes.
relnote-firefox: ? → 44+
Flags: needinfo?(margaret.leibovic)
You need to log in before you can comment on or make changes to this bug.