add support to autophone for tcheck2

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jmaher, Assigned: jmaher)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox41 affected)

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Assignee)

Description

4 years ago
tcheck2 is a robocop based test- this will not be a similar script to tp4m/tsvg as defined in bug 1172105- here I would like to have a custom talos-robocop.py script to run tcheck2.

This would need to install the unittests via enable_unittests=True.

here is the adb command line we use:
    url = ('am instrument -w -e deviceroot %s -e class'
           ' ${robocopTestPackage}.tests.testCheck2'
           ' ${robocopTestName}/${robocopTestPackage}'
           '.FennecInstrumentationTestRunner')

I think we can do something similar, but we need to make this work smoother.  I think there are also preferences for robocop that we will need.  This does not need pageloader.xpi.
(Assignee)

Comment 1

4 years ago
as a note, tcheck2 is already in robocop.apk- we just need to call it with the right parameters and parse the output we care about.

for talos we do 5 cycles and report the median of it.
(Assignee)

Updated

4 years ago
Depends on: 1176579
(Assignee)

Updated

4 years ago
Depends on: 1176582
(Assignee)

Updated

4 years ago
Depends on: 1176583
(Assignee)

Comment 2

4 years ago
Created attachment 8625145 [details]
initial robocop.py that gets robocop running

a lot of work remains here, specifically:
* refining the preferences
* solving log parsing
* installing/uninstall robocop.apk
* figuring how the right level of code refactoring/sharing with other modules
(Assignee)

Comment 3

4 years ago
Created attachment 8625156 [details]
a bit cleaned up version of robocop- still a lot to do
Attachment #8625145 - Attachment is obsolete: true
(Assignee)

Updated

4 years ago
Depends on: 1176854
(Assignee)

Comment 4

4 years ago
Created attachment 8626163 [details]
working run of tcheck2

depends on some s1s2test.py/perftest.py changes, as well as a custom cnn/cnn.com/index.html pageset.
Attachment #8625156 - Attachment is obsolete: true
(Assignee)

Comment 5

4 years ago
Created attachment 8634102 [details]
robocop.py - current version
Assignee: nobody → jmaher
Attachment #8626163 - Attachment is obsolete: true
Status: NEW → ASSIGNED
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1176582
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1176583
(Assignee)

Comment 8

4 years ago
Created attachment 8656057 [details] [review]
https://github.com/mozilla/autophone/pull/38

updated with a few nits found during local testing, this is looking good.
Attachment #8634102 - Attachment is obsolete: true
Attachment #8656057 - Flags: review?(bob)

Comment 9

4 years ago
Comment on attachment 8656057 [details] [review]
https://github.com/mozilla/autophone/pull/38

r+ with the nits addressed. Don't merge the pull request but merge your branch into master after you rebase. If you have any questions, feel free to ask.
Attachment #8656057 - Flags: review?(bob) → review+
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.