TelemetrySession::detachObservers - Failed to remove cycle-collector-begin

RESOLVED WONTFIX

Status

()

Toolkit
Telemetry
RESOLVED WONTFIX
3 years ago
13 days ago

People

(Reporter: dhylands, Unassigned)

Tracking

Trunk
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
When I power off my FirefoxOS phone (observed on Aries and Flame devices) then I see the following in logcat (2 or 3 times):

13:38:19.271 1615/1615                  Settings  I   1433536699280	Toolkit.Telemetry	WARN	TelemetrySession::detachObservers - Failed to remove cycle-collector-begin: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/modules/TelemetrySession.jsm :: detachObservers :: line 1426"  data: no] Stack trace: detachObservers()@resource://gre/modules/TelemetrySession.jsm:1426 < uninstall()@resource://gre/modules/TelemetrySession.jsm:1683 < Impl.observe()@resource://gre/modules/TelemetrySession.jsm:1755 < <file:unknown>

I also see this:
> 07:03:10.339  209/ 209              GeckoConsole  E   [JavaScript Error: "TelemetryScheduler.shutdown - Already shut down" {file: "resource://gre/modules/TelemetrySession.jsm" line: 662}]

I also see the following (on my flame - I forgot to check on my Aries device) at power on time (not sure if its relevant or perhaps should be a separate bug):

> 07:00:54.929  209/ 209              GeckoConsole  E   [JavaScript Error: "A promise chain failed to handle a rejection. Did you forget to '.catch', or did you forget to 'return'?
> 07:00:54.929  209/ 209              GeckoConsole  E   See https://developer.mozilla.org/Mozilla/JavaScript_code_modules/Promise.jsm/Promise
> 07:00:54.929  209/ 209              GeckoConsole  E   
> 07:00:54.929  209/ 209              GeckoConsole  E   Date: Fri Jun 05 2015 > 07:00:48 GMT-0700 (UTC)
> 07:00:54.929  209/ 209              GeckoConsole  E   Full Message: TypeError: invalid 'in' operand hls
> 07:00:54.929  209/ 209              GeckoConsole  E   Full Stack: getHistograms@resource://gre/modules/TelemetrySession.jsm:1034:1
> 07:00:54.929  209/ 209              GeckoConsole  E   Impl.assemblePayloadWithMeasurements@resource://gre/modules/TelemetrySession.jsm:1313:19
> 07:00:54.929  209/ 209              GeckoConsole  E   getSessionPayload@resource://gre/modules/TelemetrySession.jsm:1381:19
> 07:00:54.929  209/ 209              GeckoConsole  E   Impl._saveAbortedSessionPing@resource://gre/modules/TelemetrySession.jsm:1995:17
> 07:00:54.929  209/ 209              GeckoConsole  E   setupChromeProcess/this._delayedInitTask<@resource://gre/modules/TelemetrySession.jsm:1518:19
> 07:00:54.929  209/ 209              GeckoConsole  E   TaskImpl_run@resource://gre/modules/Task.jsm:314:40
> 07:00:54.929  209/ 209              GeckoConsole  E   Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:887:23
> 07:00:54.929  209/ 209              GeckoConsole  E   this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:766:7
> 07:00:54.929  209/ 209              GeckoConsole  E   this.PromiseWalker.sche
(Reporter)

Updated

3 years ago
OS: Unspecified → Gonk (Firefox OS)
Hardware: Unspecified → ARM
Version: unspecified → Trunk
Closing this as Gonk is no longer supported. The problem is being addressed for tests on desktop by bug 1348890.
Status: NEW → RESOLVED
Last Resolved: 13 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.