Closed Bug 117226 Opened 20 years ago Closed 20 years ago

MailNews will not appear until the first web page is completely downloaded

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: bwheadley, Assigned: sspitzer)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011221
BuildID:    2001122108

Browser comes up loading a default/home page. MailNews will not come up until
the browser successfully completely downloads a web page. Insufficient to press
the Stop Button. But if you DO Stop a page download, have it successfully
complete downloading another page, THEN mailnews will come up, from either the
Tasks menu, or the MailNews icon in the lower left corner.

Behavior seen in Linux; unknown if present in other versions.

Reproducible: Always
Steps to Reproduce:
1.Sorry, put that in the summary
2.Start up Moz
3.Press MailNews icon, or choose from menu
4.You have to wait for it to successfully download ** A ** page (need not be the
default or home page. ANY old page). THEN, MailNews will come up if you press
it's icon or go through the Task menu

Actual Results:  It sits there, continuing to,
1. If not stopped, downloading the original page.
2. If not given another page to get, looking stupid until you do so
   a. And let it successfully complete. Success does not mean pressing
      the Stop key.
   b. It will happily ignore your requests for MailNews for as long as
      you care to ask for it, until (2a) is successfully fulfilled.


Expected Results:  If you ask for MailNews whilst a page is being
downloaded/displayed, a MailNews window should appear, whilst the page download
continues.

No crash, or anything like that.

*** This bug has been marked as a duplicate of 76495 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
I do not believe that these bugs are related. Your patches (which should be
integrated into the codebase; they're dated April 2001, and this is 0.97 from
Dec 2001.

Your patch deals with pages being deleted while an activity is pending. My issue
does not involve any pages being deleted. The browser is up, it's downloading
HTTP content, but while it is doing that, I want the MailNews module to be invoked.

1. If the browser successfully GETS a page (any page), MailNews will be invoked.
This includes obtaining/rendering "about:"
2. If a successful GET has not occurred, you cannot bring up MailNews. You
expect this to be a threading issue; but pressing the STOP button to halt the
HTTP get process (making the browser component's thread idle) does not resolve
the issue.

What it appears to be: MailNews will not be invoked until a semaphore variable
is in a given state. Said variable appears to have it's state changed after
successfully getting/rendering HTTP content. It SHOULD be changed after
successful realization of the initial display screen, that which contains the
browser component.
This does not sound like a dupe of that bug, reopening.  Not sure if this still
applies, though.  Reporter, do you still see the problem?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
No response from reporter -> WFM

pi
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.