Floating panel level:parent remains in view when parent window is minimized

REOPENED
Unassigned

Status

()

Core
Layout: View Rendering
REOPENED
3 years ago
2 years ago

People

(Reporter: Kevin Jones, Unassigned)

Tracking

49 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8616432 [details]
floating_panel_demo@labodemo.org.xpi

With a xul:panel with `level` attribute set to `parent`, when minimizing the parent window, the xul:panel remains in view.

Expected behavior: The xul:panel should be hidden when the parent window is minimized.

Regression:

2013-05-01-03-10-41-mozilla-central - good
2013-05-02-03-09-39-mozilla-central - bad

Attaching xpi to demonstrate the effect.  To demonstrate, install the addon, Go to Tools menu, and click the item, "Floating panel - level parent".  After the panel appears, minimize the parent window and observe that panel disappears in the "good" regression, but remains visible in the "bad" regression.

Comment 1

3 years ago
Push log
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=02aa81c59df6&tochange=70e0955ccc87
Component: Untriaged → Extension Compatibility
Keywords: addon-compat, regression
(Reporter)

Comment 2

2 years ago
Me jumping up and down here, wondering why this bug has gone so long (5 months) without attention.  It adversely affects All Tabs Helper; I have sort of a workaround but it is not always successful.  Thanks :-)
(Reporter)

Updated

2 years ago
Component: Extension Compatibility → Untriaged
Product: Firefox → Core
Version: unspecified → 40 Branch
Hi Allasso, Requesting more information.

What platform/OS did you encounter this bug? Thanks!
Flags: needinfo?(allassopraise)
(Reporter)

Comment 4

2 years ago
Confirmed on OS X, however I believe the user who reported it to me was using Windows.
Flags: needinfo?(allassopraise)
Triaged as Layout: View Rendering as we are cleaning out the Untriaged list. If you feel this is the wrong component for the bug, please triage to the correct component. Thanks!
Component: Untriaged → Layout: View Rendering
OS: Unspecified → Mac OS X

Comment 6

2 years ago
I can't reproduce this on windows 8.1.
The panel also disappears when I press the minimize button with all three options.
This bug has been tagged for regression and or closure.
Fixed: I cannot produce the error in Nightly or Release 
Considering this I will mark this issue as Resolved-WORKSFORME. 
If anyone can still reproduce it, feel free to reopen the issue and provide updated steps/links.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(In reply to Gingerbread Man from comment #1)
> Push log
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=02aa81c59df6&tochange=70e0955ccc87

Guessing this was caused by bug 851641 http://hg.mozilla.org/mozilla-central/rev/3ff6533160bd
Blocks: 851641
Can you confirm if the bug is fixed?
Flags: needinfo?(allassopraise)
(Reporter)

Comment 10

2 years ago
Not fixed.  I still have the same result in Nightly 49.0a1 (2016-05-16), OS X.

The panel initially animates to the dock with the browser window, then suddenly re-appears on the screen once the animation completes.
Flags: needinfo?(allassopraise)
(Reporter)

Comment 11

2 years ago
Comment 10: Tested using the attached xpi.
Windows 8.1 good, I can produce in Mac OS X 10.11 
Version 	49.0a1
Build ID 	20160517030211
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:49.0) Gecko/20100101 Firefox/49.0
Status: RESOLVED → REOPENED
Ever confirmed: true
Keywords: addon-compat, regression
Resolution: WORKSFORME → ---
Version: 40 Branch → 49 Branch
You need to log in before you can comment on or make changes to this bug.