Loss of tab-groups and pinned tabs.

RESOLVED DUPLICATE of bug 630775

Status

()

RESOLVED DUPLICATE of bug 630775
3 years ago
3 years ago

People

(Reporter: achowe, Unassigned)

Tracking

38 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150513174244

Steps to reproduce:

1. Create one or more pinned tabs.
2. Create two or more tab groups with one or more tabs.
3. Right-click on tab and move a tab to new window B.
4. Close window A
5. Close window B
6. Restart Firefox. 


Actual results:

1. When window B is created (step 3), pinned tabs should also appear.
2. Pinned tabs and tab-groups lost on restart.


Expected results:

1. Pinned tabs should be shared across all windows (except private windows).
2. Tab-groups should be persistent across all restarts and not influenced by window close order; when shutting down a computer with FF running, could closes multiple windows in any order and so loose tab-groups.

Commentary:
I often have several tab-groups I keep for weeks/months.  For a couple of years now since tab-groups where added I've been wondering how I keep mysteriously loosing my pinned tabs and tab-groups.  It occurred often enough that I started backing up some technical tab-groups into bookmark folders just in case I lost tab-groups again.

Tab-groups should not be tied to a window, but to session.  Would allow moving any tab group to any window. 

Consider tab-group context menu items:
- open group in new window
- save group as bookmark folder; implementing tab-groups as bookmark folders would seem ideally.
Your bugreport is about 2 issues. In future, please file 1 report per issue. Having two issues in one report makes it hard to keep track of them correctly and confuses people that find a bug later and try to figure out what it's about / how to fix it.

With that out of the way:

1) pinned tabs in Firefox aren't shared between windows. That's a conscious decision. Background is in bug 587873.

2) window close order and which windows are restored: if you want all your windows restored, use File > Exit when closing Firefox. Ideally, we should deal better with "detecting" whether you're closing all windows in a row in order to exit Firefox. That's bug 630775. In the meantime, you might be able to use History > Recently Closed Windows after the restart.

This could be a dupe of both bug 587873 and 630775. I flipped a coin and picked the latter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 630775
You need to log in before you can comment on or make changes to this bug.