If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

minimize and maximize buttons are missing when a new window is opened

RESOLVED DUPLICATE of bug 117114

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 117114
16 years ago
13 years ago

People

(Reporter: Paul Brannan, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112012

When I open a new window in mozilla I get a new window without a minimize or
maximize button.  This happens with the "Gleam" sawfish theme, but not with some
other themes.


Reproducible: Always
Steps to Reproduce:
1. Set up sawfish to use the "gleam" theme
2. Start mozilla
3. Type "mozilla" at the command-line (which should run the script /usr/bin/mozilla)


Actual Results:  The new browser window opens without a maximize or a minimize
button.

Expected Results:  The new browser window should have both a maximize and a
minimize button.

This appears to be related to xfeDoCommand(openBrowser).  If I change the
mozilla script on line 160 from:

  exec $MOZ_PROGRAM -remote "xfeDoCommand(openBrowser)" 2>/dev/null >/dev/null

to:

  exec $MOZ_PROGRAM -remote "openURL(, new-window)" 2>/dev/null >/dev/null

then I get my maximize and minimize buttons.  However, using this solution, a
blank page is always opened, rather than opening the user's start page.
(Assignee)

Comment 1

16 years ago
blizzard is this stuff you know about? xfeDoCommand?
Looks like a dup.

*** This bug has been marked as a duplicate of 117114 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.