If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Linux] Clicking the Performance settings button checks the first option and dismisses the menu

RESOLVED FIXED in Firefox 43

Status

()

Firefox
Developer Tools: Performance Tools (Profiler/Timeline)
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: avaida, Assigned: nounoursheureux)

Tracking

({regression})

40 Branch
Firefox 43
All
Linux
regression
Points:
---

Firefox Tracking Flags

(firefox40 affected, firefox41 affected, firefox43 fixed)

Details

(Whiteboard: [good first bug][lang=js])

Attachments

(1 attachment, 1 obsolete attachment)

Reproducible on:
* Aurora 40.0a2 (2015-06-04)
* Nightly 41.0a1 (2015-06-07)

Affected platforms:
Linux-only, tested with Ubuntu 14.04 (x64)

Steps to reproduce:
1. Launch Firefox.
2. Toggle the Developer Tools and select "Performance".
3. Click the settings button from the Performance toolbar.

Expected result:
Clicking the button once will bring up the settings menu.

Actual result:
* Clicking the button brings up the settings menu but also selects the first option available in it, "Show Gecko Platform Data".
* As the first option is selected, the menu is automatically dismissed, making it look like the menu itself is not working properly.

Notes:
* This issue might be a regression, I'll follow up with a regression range as soon as possible.
Duplicate of this bug: 1145610
This is a pretty bad one if we can't select options on linux. Any linux users want to check this out?
Priority: -- → P1
This bug appears to be reproducible since that settings button was implemented in the first place, so I'm not really sure how reliable or relevant the following regression range is.

mozilla-central
===============
* Last good revision: af68c9c0e903
* First bad revision: 436686833af0
* Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=af68c9c0e903&tochange=436686833af0

mozilla-inbound
===============
* Last good revision: ada27d1eac50
* First bad revision: 3ef1e4e8a61e
* Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ada27d1eac50&tochange=3ef1e4e8a61e
Whiteboard: [good first bug][lang=js]
(Assignee)

Comment 4

2 years ago
Created attachment 8646255 [details] [diff] [review]
bug1172407_fix_performance_options_menu.patch

This patch should fix the popup menu :)
Attachment #8646255 - Flags: review?(jsantell)
Comment on attachment 8646255 [details] [diff] [review]
bug1172407_fix_performance_options_menu.patch

Review of attachment 8646255 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me on the change, r?ing Shu to test it out on Linux!
Attachment #8646255 - Flags: review?(shu)
Attachment #8646255 - Flags: review?(jsantell)
Attachment #8646255 - Flags: review+
Assignee: nobody → schtroumps31
Comment on attachment 8646255 [details] [diff] [review]
bug1172407_fix_performance_options_menu.patch

Review of attachment 8646255 [details] [diff] [review]:
-----------------------------------------------------------------

Seems it's not recreatable in other Linux, possibly something with the window manager in Ubuntu -- Andrei, can you confirm this patch fixes?
Attachment #8646255 - Flags: review?(shu) → review?(andrei.vaida)
(Assignee)

Comment 7

2 years ago
I'm running ArchLinux and my WM is Openbox. I had this bug and the patch fixed it.
Comment on attachment 8646255 [details] [diff] [review]
bug1172407_fix_performance_options_menu.patch

Review of attachment 8646255 [details] [diff] [review]:
-----------------------------------------------------------------

Sounds good! Adding as checkin needed
Attachment #8646255 - Flags: review?(andrei.vaida)
Thanks, Wilhem!
Keywords: checkin-needed
(Assignee)

Comment 10

2 years ago
Created attachment 8647366 [details] [diff] [review]
bug1161698_set_label_to_filename_when_importing.patch
Attachment #8646255 - Attachment is obsolete: true
Attachment #8647366 - Flags: review?(jsantell)
Attachment #8647366 - Flags: review?(jsantell) → review+
(Assignee)

Updated

2 years ago
Attachment #8647366 - Attachment is obsolete: true
(Assignee)

Updated

2 years ago
Attachment #8646255 - Attachment is obsolete: false
(Assignee)

Comment 11

2 years ago
Sorry I messed up and submitted a patch to the wrong issue ><

Comment 12

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/3180877d4e44
Keywords: checkin-needed
Landed the incorrect patch in https://hg.mozilla.org/integration/fx-team/rev/692b2fea4ef6
Backed it out in https://hg.mozilla.org/integration/fx-team/rev/b7cb976e52a6

Landed the correct patch in https://hg.mozilla.org/integration/fx-team/rev/3180877d4e44
(Assignee)

Comment 14

2 years ago
Thanks :) . So that means the issue is resolved ?
(In reply to Wilhem Barbier [:schtroumps31] from comment #14)
> Thanks :) . So that means the issue is resolved ?

Sheriffs will resolve the bug once the patch is merged to mozilla-central, usually within a day.
https://hg.mozilla.org/mozilla-central/rev/3180877d4e44
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox43: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Successfully reproduce this bug in Nightly 41.0a1 (2015-06-07) (Build ID: 20150607030217) on Linux (Ubuntu 15.04) x64

This Bug is now verified as fixed on Latest Firefox Nightly 43.0a1 (2015-08-19)

Build ID: 20150819030206
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
QA Whiteboard: [bugday-20150819]
You need to log in before you can comment on or make changes to this bug.