Closed Bug 1172497 Opened 6 years ago Closed 6 years ago

GaiaTest should not touch lockscreen when it's disabled

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: freddy, Assigned: martijn.martijn)

References

Details

Attachments

(2 files)

In a Gaia profile with NO_LOCK_SCREEN=1 I get the errors about ScreenManager not being defined (see attachment).

This is likely caused by gaia_test.py line ~864

>        # Make sure the screen isn't turned off in lockscreen mode
>        self.marionette.switch_to_frame()
>        self.marionette.execute_script(
>            'window.wrappedJSObject.ScreenManager.LOCKING_TIMEOUT = 9999;')



Dave Hunt suggested guarding that call and only execute if lockscreen is enabled.
Blocks: 1169332
(In reply to Frederik Braun [:freddyb] from comment #0)
> Dave Hunt suggested guarding that call and only execute if lockscreen is
> enabled.

The problem with that is that once the lockscreen is enabled, it uses the LOCKING_TIMEOUT value of that that time when it is engaged. It won't use the new LOCKING_TIMEOUT value.
Assignee: nobody → martijn.martijn
(In reply to Frederik Braun [:freddyb] from comment #0)
> Dave Hunt suggested guarding that call and only execute if lockscreen is
> enabled.

Ah, I guess Dave Hunt meant the lockscreen.enabled setting. Yes, I can do that.
Fwiw, I was running a gaiatest with NO_LOCK_SCREEN=1 and I couldn't reproduce this problem.
I wasn't able to reproduce this. Frederik, does this solve the issue?
I think this change is good, because every test that needs lockscreen, does use self.device.lock() for it.
Attachment #8616727 - Flags: review?(fbraun)
Attachment #8616727 - Flags: review?(dave.hunt)
Blocks: 1172029
Comment on attachment 8616727 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/30486

Yes, that would work for me.
Attachment #8616727 - Flags: review?(fbraun) → feedback+
Attachment #8616727 - Flags: review?(dave.hunt) → review+
Merged: https://github.com/mozilla-b2g/gaia/commit/e6106a94ad92b54aa6dfad8892b0a556b78b01da
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.