Interactive elements do not work at http://maps.skobbler.com/

RESOLVED FIXED in seamonkey2.39

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: RainerBielefeldNG, Assigned: philip.chee)

Tracking

({regression})

SeaMonkey 2.29 Branch
seamonkey2.39
Unspecified
Windows 7
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.35 fixed, seamonkey2.36 fixed, seamonkey2.37 fixed, seamonkey2.38 fixed, seamonkey2.39 fixed)

Details

()

User Story

http://hg.mozilla.org/releases/comm-aurora/rev/9c3b32b0cc34  SeaMonkey 2.38
http://hg.mozilla.org/releases/comm-beta/rev/5570089e9516    SeaMonkey 2.37
http://hg.mozilla.org/releases/comm-release/rev/825dd59421a3 SeaMonkey 2.36
http://hg.mozilla.org/releases/comm-release/rev/a8e2df40319e SeaMonkey 2.36

Attachments

(1 attachment)

Reporter

Description

4 years ago
Steps how to reproduce with EN-US SeaMonkey 2.33.1 (German Language pack)  Gecko/20100101 Build 20150321194901 (Classic Theme) on German WIN7 64bit:

1. In Browser open <http://maps.skobbler.com/>
   » Page appears with Map and at the left vertical bar with links for 
     Address search, Category search and so on, white characters on
     brown background
2. Click any of the links ( Address search)
   Expected: A white area, width some more than vertical brown area, 
             with input fields should appear
  Actual: Nothing
          If white area already is expanded, it will be empty instead 
          of showing input fields

Additional information:
a) Works fine with FF 38.0.5 and IE11
b) Still worked fine with EN-US SeaMonkey 2.26  (Portable) 
   Gecko/20100101 Firefox/29.0 Build 20140428215944 ( Classic Theme) 
   on German WIN7 64bit (and may be later)
c) already broken with 2.29.1
d) switching profile or Safe Mode without add-ons does not help
e) Validator <http://validator.w3.org/check?charset=%28detect+automatically%29&doctype=Inline&uri=http%3A%2F%2Fmaps.skobbler.com%2F> shows various errors on page
f) Error console shows lots of problems
g) Still a problem with  EN-US SeaMonkey 2.38a1 build by Philip Chee, 
   Gecko/20100101 , Build 20150601233926 (Classic Theme) on 
   German WIN7 64bit

Comment 1

4 years ago
> Actual: Nothing

Confirmed.

> b) Still worked fine with EN-US SeaMonkey 2.26

Confirmed.

> c) already broken with 2.29.1
> d) switching profile or Safe Mode without add-ons does not help

Confirmed.

> Error: TypeError: this._locationError is not a function
> Source File: http://maps.skobbler.com/js_new/skobbler/maps-min-dsk.js?r=4112
> Line: 33
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Comment 2

4 years ago
I think it's something to do with SeaMonkey not having a Google API key
> browser.search.geoip.url https://location.services.mozilla.com/v1/country?key=%MOZILLA_API_KEY%
> geo.wifi.uri https://www.googleapis.com/geolocation/v1/geolocate?key=%GOOGLE_API_KEY%
Assignee

Comment 3

4 years ago
In all.js we have.
browser.search.geoip.url -> https://location.services.mozilla.com/v1/country?key=%MOZILLA_API_KEY%
geo.enabled -> true

But we disabled geo.enabled in bug Bug 903439 since we didn't have a google API key. This has a side effect of disabling navigator.geolocation

http://maps.skobbler.com/ appears to use a framework called RACQUEL (River and Catchment Query and Extraction Layer http://code.google.com/p/racquel/)
RACQUEL does the following:

> else if (navigator.geolocation){
>         this.watchProcess = navigator.geolocation.watchPosition(
>         dojo.hitch(this,this._processLocation),
>         dojo.hitch(this,this._locationError),
And since navigator.geolocation is not defined, this._locationError isn't hooked up. 

Currently Gecko is using
browser.search.geoip.url -> https://location.services.mozilla.com/v1/country?key=%MOZILLA_API_KEY%
Where the default MOZILLA_API_KEY is no-mozilla-api-key.

Deleting our override to let geo.enabled -> true allows maps.skobbler.com to work.
Depends on: 903439
Summary: Web page display: Interactive elements do not work → Interactive elements do not work at http://maps.skobbler.com/
Reporter

Comment 4

4 years ago
May be geolocation message appearing at <http://www.dastelefonbuch.de/> depends on the same root?
Assignee

Comment 5

4 years ago
>+pref("geo.wifi.uri", "https://location.services.mozilla.com/v1/geolocate?key=%MOZILLA_API_KEY%");
We don't have a mozilla api key but I understand the default fallback of no-mozilla-api-key should work. Worst case we don't get any geolocation data but then we currently don't anyway.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #8630068 - Flags: review?(iann_bugzilla)
Assignee

Comment 6

4 years ago
(In reply to Rainer Bielefeld from comment #4)
> May be geolocation message appearing at <http://www.dastelefonbuch.de/>
> depends on the same root?
Yes if you set geo.enabled to true the message goes away.

Ihr Endgerät bzw. Ihr Browser unterstützt neuere Funktionen (Geolocation) nicht, die wir auf unserer Webseite nutzen.
Bitte nutzen Sie einen neueren Browser oder ein neueres Endgerät

According to Google translate this means:

Your device or your browser does more modern methods ( GPS ) is not that we use on our website .
Please use a newer browser or a newer terminal

Which isn't much clearer.

Comment 7

4 years ago
Comment on attachment 8630068 [details] [diff] [review]
Patch v1.0 enable geolocation service

a=me for CLOSED TREE too
Attachment #8630068 - Flags: review?(iann_bugzilla) → review+
Assignee

Comment 8

4 years ago
Pushed to comm-central
http://hg.mozilla.org/comm-central/rev/a77e7b1551c9
Target Milestone: --- → seamonkey2.39

Comment 9

4 years ago
Is this something we want on other branches including 2.35 release?
Flags: needinfo?(philip.chee)
Assignee

Comment 10

4 years ago
Comment on attachment 8630068 [details] [diff] [review]
Patch v1.0 enable geolocation service

(In reply to Ian Neal from comment #9)
> Is this something we want on other branches including 2.35 release?
Yes, who knows how many other websites are broken because we don't expose navigator.geolocation

[Approval Request Comment]
Regression caused by (bug #): Bug 903439
User impact if declined: Websites that use navigator.geolocation are broken.
Testing completed (on m-c, etc.): lightly tested
Risk to taking this patch (and alternatives if risky): no risk. Worse comes to the worse geolocation doesn't work but then it doesn't currently work anyway.
String changes made by this patch: none
Flags: needinfo?(philip.chee)
Attachment #8630068 - Flags: approval-comm-release?
Attachment #8630068 - Flags: approval-comm-beta?
Attachment #8630068 - Flags: approval-comm-aurora?

Comment 11

4 years ago
Comment on attachment 8630068 [details] [diff] [review]
Patch v1.0 enable geolocation service

a=me
Attachment #8630068 - Flags: approval-comm-release?
Attachment #8630068 - Flags: approval-comm-release+
Attachment #8630068 - Flags: approval-comm-beta?
Attachment #8630068 - Flags: approval-comm-beta+
Attachment #8630068 - Flags: approval-comm-aurora?
Attachment #8630068 - Flags: approval-comm-aurora+
Assignee

Updated

4 years ago
Assignee

Updated

4 years ago
User Story: (updated)
You need to log in before you can comment on or make changes to this bug.