test_instance_re-parent.html is going to permafail when Gecko 40 merges to Beta.

RESOLVED WONTFIX

Status

()

defect
--
critical
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: RyanVM, Assigned: aklotz)

Tracking

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox39 fixed, firefox40 disabled, firefox41 disabled, firefox42 disabled, firefox43 affected, firefox-esr38 fixed)

Details

Attachments

(2 attachments)

[Tracking Requested - why for this release]: Permafail when Gecko 40 merges to Beta.

Aaron, any idea what's going on here?

https://treeherder.mozilla.org/logviewer.html#?job_id=8236329&repo=try

21:21:05 INFO - 2554 INFO TEST-UNEXPECTED-FAIL | dom/plugins/test/mochitest/test_instance_re-parent.html | Testing for exception getting instance count from plugin. - got true, expected false
21:21:05 INFO - 2555 INFO TEST-UNEXPECTED-FAIL | dom/plugins/test/mochitest/test_instance_re-parent.html | uncaught exception - TypeError: p.stopWatchingInstanceCount is not a function at http://mochi.test:8888/tests/dom/plugins/test/mochitest/test_instance_re-parent.html:86
21:21:05 INFO - JavaScript error: http://mochi.test:8888/tests/dom/plugins/test/mochitest/test_instance_re-parent.html, line 86: TypeError: p.stopWatchingInstanceCount is not a function
Flags: needinfo?(aklotz)
Probably more fallout from bug 1158761. I'll look into it.
Flags: needinfo?(aklotz)
Posted patch Update testSplinter Review
Post bug 1158761 it's no longer guaranteed that a plugin instance will be stopped within one event loop iteration. I think that's what we were seeing here. This patch updates the test to try again a few times, just like the other tests that were updated in bug 1158761.
Assignee: nobody → aklotz
Status: NEW → ASSIGNED
Attachment #8617050 - Flags: review?(jmathies)
Attachment #8617050 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/2a981c61aa56
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Flags: needinfo?(ryanvm)
Marking the dep on bug 1158761 in the event that we successfully uplift it to Beta39 at some point.
Blocks: 1158761
Flags: needinfo?(ryanvm)
Tracking enabled for 40 to verify that a fix makes it in.
It's testonly so according to tree rules I don't need approval to land.
https://hg.mozilla.org/releases/mozilla-aurora/rev/b2717492637e
This is still happening on Try push off Aurora tip from a couple days ago.
https://treeherder.mozilla.org/logviewer.html#?job_id=8744443&repo=try
Status: RESOLVED → REOPENED
Flags: needinfo?(aklotz)
Resolution: FIXED → ---
Target Milestone: mozilla41 → ---
I've been seeing bugmail for bug 976824 as well. Looks like we'll need to increase the retry threshold for the affected tests.
We essentially just need to wait longer for the plugin stop event to propagate.
Flags: needinfo?(aklotz)
Attachment #8625816 - Flags: review?(jmathies)
Attachment #8625816 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/e419080121a3
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Ryan, can you handle the a=testonly uplift, please?
Flags: needinfo?(ryanvm)
Whoops, I actually did already but forgot to mark the bug. Whoopsie.
Flags: needinfo?(ryanvm)
test_instance_re-parent.html disabled in https://hg.mozilla.org/releases/mozilla-beta/rev/f1bf17bff7c4

Hopefully that's the only one that needs it.
Flags: needinfo?(aklotz)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla41 → ---
Should be. That one seems to be the trouble spot. I'll look at it some more.
Flags: needinfo?(aklotz)
Test disabled on beta so I'm clearing the tracking flag there.
Blocks: 1189887
Disabled again for Beta41.

https://hg.mozilla.org/releases/mozilla-beta/rev/e60aa8081057

Aaron, let's just disable this across the board since there's clearly not much motivation to get it fixed.
I am working on it, can reproduce it in a VM. Trying to get this cleared up now.
Flags: needinfo?(aklotz)
Thanks. This is still on my radar and I'll remove the skip-ifs as soon as I fix the tests.
Flags: needinfo?(aklotz)
removing the b2g 2.5 flag since this commit has been reverted due to an incorrect merge, sorry for the confusion
I think we should wontfix this. What do you think?
Flags: needinfo?(aklotz)
Sure.
Flags: needinfo?(aklotz)
Status: REOPENED → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.