Admins can't override failed validation for betas

RESOLVED FIXED in 2015-06

Status

--
major
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jorgev, Assigned: magopian)

Tracking

(Blocks: 1 bug)

unspecified
2015-06
Dependency tree / graph

Details

(Reporter)

Description

3 years ago
I was trying to upload a beta version for Tab Mix Plus, to work around bug 1172035, but the "override failed validation" checkbox was disabled. I had to tweak the DOM so that it would work.

The override option should be available in these cases.
(Assignee)

Comment 1

3 years ago
The admin "override failed validation" checkbox is only enabled when there's errors during the validation (either errors returned by the validator, or an error from the validator or contacting the validator/getting the results back).

In your case, can you confirm there was no errors? If so, it's by design that the checkbox was disabled.

What I understand is that this bug would be solved if bug 1172030 was implemented, is that right?

Or would you like the checkbox to be enabled all the time?
Flags: needinfo?(jorge)
(Reporter)

Comment 2

3 years ago
Fixing bug 1172030 should also fix this bug, yes, but I think it's best to keep the checkbox enabled in case similar issues pop up in the future.
Flags: needinfo?(jorge)
(Assignee)

Comment 3

3 years ago
Ok, after discussing on irc with :kmag, here's what needs to be done:

1/ keep the current behavior for listed addons (only enable the checkbox if there are errors returned by the validator)
2/ enable the checkbox for unlisted addons if there are errors or warnings that prevent the automatic validation (if there are messages with a signing severity above trivial)

For point 2/, this would just bypass the automatic validation, and put the extension in the unlisted review queue that it should be in (prelim for standard ones, full for side-load)
(Assignee)

Comment 4

3 years ago
Comment 3 is misleading, and partly incorrect, so please disregard it. This bug is in the context of beta files submission, not unlisted add-ons submission.

At the moment, if a beta file doesn't pass automatic validation, it's simply not accepted, because it's not going to be reviewed manually. There's an open bug (bug 1172035) to maybe fix that. In that case, this bug wouldn't be needed anymore: if there's errors, an admin could override the validation, as it's already the case for listed/unlisted addons.

An alternative to fixing bug 1172035 would be to have the "admin override" enabled if a beta file fails validation (because of an error or because of signing_severity warnings), and using it would force the signing of the file.

Is that what you want Jorge?
Depends on: 1172035
Flags: needinfo?(jorge)
(Reporter)

Comment 5

3 years ago
(In reply to Mathieu Agopian [:magopian] from comment #4)
> An alternative to fixing bug 1172035 would be to have the "admin override"
> enabled if a beta file fails validation (because of an error or because of
> signing_severity warnings), and using it would force the signing of the file.
> 
> Is that what you want Jorge?

Yes, admins should always be capable of overriding a failed validation. The fix we're discussing for bug 1172035 (accepting all betas) would hide this bug, but I would still prefer that we have a solution for this in case we change the way we deal with betas.
Flags: needinfo?(jorge)
(Assignee)

Comment 6

3 years ago
PR: https://github.com/mozilla/olympia/pull/590
Assignee: nobody → mathieu
Blocks: 1070153

Comment 7

3 years ago
Commits pushed to master at https://github.com/mozilla/olympia

https://github.com/mozilla/olympia/commit/46f4b6fdf56c32ea41a7c086961f2768cf5ee3a7
Can now admin override failed auto-validation of beta files (bug 1172690)

https://github.com/mozilla/olympia/commit/190854e027390f28d5abede97a685fab1f1c9dbf
Merge pull request #590 from magopian/1172690-admin-override-failed-auto-validation-beta-files

Can now admin override failed auto-validation of beta files (bug 1172690)
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 8

3 years ago
Commit pushed to master at https://github.com/mozilla/olympia

https://github.com/mozilla/olympia/commit/974107e240718018e12cd246640d8409f1737e2f
Remove the 'admin override' parameter for auto signing

auto signing files doesn't need to know about "admin override". Putting
a file as "admin override" doesn't make it automatically signed. This
parameter was added in a previous version to allow auto-signing of
submitted beta files that were admin overriden, but since we auto-sign
all the beta versions, we don't need it anymore.

See
https://github.com/mozilla/olympia/commit/46f4b6fdf56c32ea41a7c086961f2768cf5ee3a7
(bug 1172690).
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.