Closed Bug 1172708 Opened 5 years ago Closed 5 years ago

Upgrading to a version of Firefox that supports signing and disables add-ons displays the compatibility notification

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla41
Tracking Status
firefox40 + verified
firefox41 + verified

People

(Reporter: mossop, Assigned: mossop)

References

Details

Attachments

(1 file)

1. Run release and enable xpinstall.signatures.required=true
2. Install an unsigned add-on.
3. Run Nightly.

Nightly should start normally and then display the doorhanger from https://bug1148403.bugzilla.mozilla.org/attachment.cgi?id=8598783. Instead it shows the compatibility UI saying that the add-on isn't compatible Sort of correct but not the behaviour we want.
The patch in bug 1172710 makes us show both the compatibility dialog and the doorhanger in this case
Attached patch patchSplinter Review
This doesn't include add-ons that are already compatible in the compatibility UI so add-ons that are only disabled because of their signing won't be in there anymore. Adds automated tests to verify that.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #8617011 - Flags: review?(dveditz)
QA Contact: vasilica.mihasca
Tracked for 40 and 41.
Comment on attachment 8617011 [details] [diff] [review]
patch

Review of attachment 8617011 [details] [diff] [review]:
-----------------------------------------------------------------

r=dveditz
Attachment #8617011 - Flags: review?(dveditz) → review+
https://hg.mozilla.org/mozilla-central/rev/77a1a1eaad91
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Comment on attachment 8617011 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: Add-on signing
[User impact if declined]: When upgrading to 40 with signing enabled users will see the compatibility dialog blocking startup unnecessarily
[Describe test coverage new/current, TreeHerder]: On m-c with automated tests
[Risks and why]: Low risk, the change is straightforward
[String/UUID change made/needed]: None
Attachment #8617011 - Flags: approval-mozilla-aurora?
Comment on attachment 8617011 [details] [diff] [review]
patch

New feature with 40, we want that to be clean.
Attachment #8617011 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: qe-verify+
I was able to reproduce this issue on Firefox 41.0a1 (2015-06-08) using Windows 7 64-bit.

Verified fixed on Firefox 41.0a1 (2015-06-16/17) and Firefox 40.0a2 (2015-06-17) under Windows 7 64-bit, Ubuntu 14.04 32-bit and Mac OS X 10.9.5.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.