Closed Bug 1172710 Opened 5 years ago Closed 5 years ago

Breaking an add-on signing doesn't show a notification on next startup.

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla41
Tracking Status
firefox40 + verified
firefox41 + verified

People

(Reporter: mossop, Assigned: mossop)

References

Details

Attachments

(1 file)

1. Run nightly and enable xpinstall.signatures.required.
2. Install a signed add-on.
3. Quit nightly and modify the add-on's files in the profile in some way, adding a file to its XPI or directory is fine.
4. Start nightly.

We should show the notification from https://bug1148403.bugzilla.mozilla.org/attachment.cgi?id=8598783 but we seem to show nothing, the add-on does get disabled though.
Attached patch patchSplinter Review
I must have been half asleep when I reviewed this, this works in manual testing.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #8616988 - Flags: review?(dao)
QA Contact: vasilica.mihasca
Comment on attachment 8616988 [details] [diff] [review]
patch

Somehow I must have misread AddonManager.jsm and think getAddonByID worked synchronously. Unfortunately, I had no idea how to test this manually...
Attachment #8616988 - Flags: review?(dao) → review+
Tracking 40 and 41 because they are affected.
sorry had to back this out in https://treeherder.mozilla.org/#/jobs?repo=fx-team&revision=70776f034a7c since this or the other cset caused a perma failure in xperf like https://treeherder.mozilla.org/logviewer.html#?job_id=3392932&repo=fx-team
Flags: needinfo?(dtownsend)
Re-landing as this didn't cause the failure.

https://hg.mozilla.org/integration/fx-team/rev/4a7f005e7841
Flags: needinfo?(dtownsend)
https://hg.mozilla.org/mozilla-central/rev/4a7f005e7841
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Comment on attachment 8616988 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: Add-on signing
[User impact if declined]: Users won't be notified if some of their add-ons fail the signing check
[Describe test coverage new/current, TreeHerder]: On m-c since last week, no way to automate tests here but I've manually verified it
[Risks and why]:  The risk of other fall-out is low, the worst case is that this feature would continue to be broken.
[String/UUID change made/needed]: None
Attachment #8616988 - Flags: approval-mozilla-aurora?
Comment on attachment 8616988 [details] [diff] [review]
patch

Improve the UX of this new feature. Taking it.
Attachment #8616988 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: qe-verify+
I was able to reproduce this issue on Firefox 41.0a1 (2015-06-08) using Windows 7 64-bit.

Verified fixed on Firefox 41.0a1 (2015-06-17) and Firefox 40.0a2 (2015-06-17) under Windows 7 64-bit, Ubuntu 14.04 32-bit and Mac OS X 10.9.5
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.