Closed Bug 1172736 Opened 6 years ago Closed 6 years ago

[Power Options] If user swipes to a side in the empty space the next time they hit cancel will not exit the menu

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED DUPLICATE of bug 1172224
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: AdamA, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing][Spark])

Attachments

(1 file)

Summary (title) Field:
[Power Options] If user swipes to a side in the empty space the next time they hit cancel will not exit the menu

Description:
When the user holds the power button to open the power options menu they can swipe to the side in the blank space below the options and the next time the cancel button is pressed it will not actually exit the menu. this can be done multiple times in a row.

Repro Steps:
1) Update a Aries to 20150608110222
2) Hold the power button to open the power options menu
3) Swipe to the left in the empty space between the options and the cancel button
4) Press the cancel button
5) Observe still being on the power options menu

Actual:
The power options menu does not dismiss when cancel is pressed\

Expected:
It is expected that the power options menu is dismissed when the cancel button is pressed.

Environmental Variables:
Device: Aries 3.0 (Full Flash)
Build ID: 20150608110222
Gaia: 592b6cf0ffc7f487b0c52a8a74ce8ac389a593c6
Gecko: 4700d1cdf489
Gonk: 3af1ede0d0956cfbf9c549df7cd9a6807a9efdf2
Version: 41.0a1 (3.0)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Repro frequency: 10/10
See attached: video clip(http://youtu.be/GFMs9uQ_gDM), logcat
This issue DOES occur on Spark 3.0 builds, as well as Flame 3.0.

Environmental Variables:
Device: Flame 3.0
Build ID: 20150608010204
Gaia: 1d62b32408567f9f7cf1c71c1e5a0c6593be757b
Gecko: 7d4ab4a9febd
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

---------------------
This issue DOES NOT occur on Flame 2.2, 2.1, and 2.0.

Environmental Variables:
Device: Flame 2.2
Build ID: 20150602002504
Gaia: a675e5472944a9d7a16e091ba8a59901e37df9e0
Gecko: c163c2a5b921
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1
Build ID: 20150601001204
Gaia: 2304a1f6327c2ccf35d6995ee16f2231ed1f22a3
Gecko: e52807dee101
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0
Build ID: 20150601000202
Gaia: 5552bf529d3d6775a968942e9afa6c1d4037362c
Gecko: a592339c2d65
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [3.0-Daily-Testing][Spark]
QA Contact: jmercado
[Blocking Requested - why for this release]:
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
The changes for bug 1162064 seem to have caused this issue.  Please see the pushlog.

Mozilla-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150604121745
Gaia: e0fbadeb78a96137f071d9be7a47ef9fe882d17f
Gecko: 4ed228a6c759
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150604140143
Gaia: e0fbadeb78a96137f071d9be7a47ef9fe882d17f
Gecko: 227d356ac030
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: e0fbadeb78a96137f071d9be7a47ef9fe882d17f
Gecko: 227d356ac030

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: e0fbadeb78a96137f071d9be7a47ef9fe882d17f
Gecko: 4ed228a6c759

Gecko Pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4ed228a6c759&tochange=227d356ac030
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
David, can you take a look at this please? This might have been caused by the landing for bug 1162064.
Blocks: 1162064
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(dvander)
Should re-test after bug 1172224 makes it to central, to see if that was the problem.
Testing locally seems to indicate that this is fixed by bug 1172224. Adding qawanted to confirm; please dupe this to bug 1172224 if you can confirm.
Keywords: qawanted
This issue has been fixed on Spark

The cancel button works as intended after swiping your finger between the available options and the cancel button on the power menu.

Device: Aries 3.0
Build ID: 20150610170534
Gaia: e3eaf72ccd1bfe6d60d37efde6d3b92c1dbc5ff9
Gecko: 95afddf894e3
Gonk: 75c7e6ca80d0c7a53f346ecfcde2343be95808c9
Version: 41.0a1 (3.0)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

-------------------------------

This issue still occurs on the Flame 3.0 but I don't see a build for today so that makes sense.

The "Cancel" button does not work after swiping your finger between the available options and the cancel button. 

Environmental Variables:
Device: Flame 3.0 Kitkat Full Flash (319mb)
BuildID: 20150609160220
Gaia: 31ef8deec7a04a988eb92309178b87cc0bde8220
Gecko: 8be8deb10e4f
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Keywords: qawanted
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1172224
You need to log in before you can comment on or make changes to this bug.