Firefox won't launch from icon in Mac OS 10.11

RESOLVED DUPLICATE of bug 1166515

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1166515
3 years ago
3 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox38.0.5 affected, firefox39 unaffected, firefox40 unaffected, firefox41 unaffected)

Details

(Reporter)

Description

3 years ago
Platform: OS X 10.11 (15A178w) Darwin 15.0.0

I just installed Mac OS X El Capitan developer preview and noticed a weird Firefox startup bug. It seems I cannot start Firefox with the icon but if I run the firefox command from terminal it launches okay.

Steps:
1) Download Firefox and put it in Applications
2) Open Finder and go to Applications
3) Double click the Firefox icon to launch
> "Firefox is damaged and can't be opened."
(the same occurs if launching Firefox from Spotlight)
(the same occurs if launching Firefox from the mounted dmg)
4) Open terminal
5) Run "/Applications/Firefox.app/Contents/MacOS/firefox"
> Firefox starts as expected

This bug only seems to reproduce in Firefox 38.0.5; Firefox Beta, Aurora, and Nightly open fine from the icon-based launchers.
(Reporter)

Comment 1

3 years ago
[Tracking Requested - why for this release]: nominating to track simply to increase awareness of the issue. This may end up being an OS X bug that will be "fixed" in a future update.
status-firefox38.0.5: --- → affected
status-firefox39: --- → unaffected
status-firefox40: --- → unaffected
status-firefox41: --- → unaffected
tracking-firefox38.0.5: --- → ?
Blocks: 1173135
Status: NEW → RESOLVED
Last Resolved: 3 years ago
tracking-firefox38.0.5: ? → ---
Resolution: --- → DUPLICATE
Duplicate of bug: 1166515
You need to log in before you can comment on or make changes to this bug.