Applet is displayed outside of the browser window

RESOLVED WORKSFORME

Status

()

defect
P3
normal
RESOLVED WORKSFORME
20 years ago
5 years ago

People

(Reporter: pawyskoczka, Assigned: peterlubczynski-bugs)

Tracking

Trunk
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Overview Description:
Once the html page that contains the applet is displayed, the applet is
displayed at the bottom left hand corner of the browser but outside the actual
browser window.

Steps to Reproduce:
1)Launch the browser
2)Load the following url:
http://blues/users/bsharma/publish/ojitests/Tags/APPLET/acceptance.html
3) Wait until the html page has been displayed
4) Applet is displayed outside the browser window
5) Scrolling up/down causes a repainting problem

Actual Results:
Applet is displayed outside the browser window

Expected Results:
Applet is displayed inside the browser window


Build Date & Platform Bug Found:
1999081108 Macintosh

Additional Builds and Platforms Tested On:
Need to install OJI stuff for Mac.  http://www.mozilla.org/oji/MRJPlugin.html

Additional Information:
This testcase works fine on Windows.
Assignee: troy → beard
This seems to be a Macintosh specific problem. Maybe you know who should get the
bug
Assignee: beard → mark.lin
Mark, I talked to Patrick Beard and he said you might be the person to look at this problem.
Is this on 4.X only or 5.X or both?

I can't access the url mentioned above because I don't have access to netscape
internal servers. Would it be possible for you to send me a zip file of the
stuff? Also, if you have any other OJI test cases, that would be great as well.
Thanks.
By "outside the browser window" do you mean that the Applet's bounding area
overlaps AppRunner's toolbars and scrollbars when you start scrolling (a
heavyweight / lightweight problem)? Or do you mean the Applet window actually
exists outside the window which contains AppRunner?

I guess browser window is an overloaded term here. Are you referring to the html
pane which is being scrolled via AppRunner's scrollbars, or are you referring to
the top-level window that contains the whole browser (toolbars, buttons
included).
If you open the apprunner and load this url so that the applet box is only about 1/2 displayed at the bottom left.  When with applet starts,
the applet box with the applet running sits over the bottom scroll bar.  Half of the box is in the html window and half is outside it.  If you
then scroll up the html page the applet does not move, but by scrolling,  a number of partial black rectangles will be drawn on the html
page.  To answer your questions, I am talking about the html page and that the applet bounding area is overlaping the bottom scroll
bar.  Hope this helps.
Status: NEW → ASSIGNED
Yes, thanks. I understand now. I will have to ask Patrick about this bug. I

think it has to do with the way the Mac draws it's windows
This may well be an MRJ problem -- we saw exactly the same problem in IE and iCab

that was recently fixed internally in MRJ 2.2.  MRJ 2.2ea2 is due out soon; you

may want to check and see if it's fixed in there.



Browsing randomly through bugs,

Eric

MRJ team (writing from home)
Assignee: mark.lin → av
Status: ASSIGNED → NEW
Component: Layout → Plug-ins
I talked with Patrick Beard about this bug. He and I both agreed that all
plugins on the Mac are going to have this problem. So I'm going to reclassify
this as a plugin bug. Let me know if you need help reproducing or tracking down
the bug.

The behavior is that the plugin gets painted/drawn over the scrollbar regions of
the browser, and also, when you start scrolling the browser window up and down,
it leaves paint trails behind. The reason this is happening is because I suspect
the plugin's content region is not being revalidated correctly.
*** Bug 11743 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Can anybody confirm this is still present?
Target Milestone: M15
Target Milestone: M15 → M17
Is this still happening?
Added shrir@netscape.com to cc list.
Shrir could you take a look at this bug and provide some input as to whether it 
is still happening.
This applet appears fine (inside the browser window)on mac build 2000061214m17.
This is still happening for me.  Here are some URLs of images that show the 
problem:

1) The initial load of my applet:
http://pjgray.ne.mediaone.net/images/avid/initial_load.jpg

2) Scrolling the applet up:
http://pjgray.ne.mediaone.net/images/avid/scroll_up.jpg

3) Scrolling the applet back down:
http://pjgray.ne.mediaone.net/images/avid/scroll_down.jpg

4) Showing the applet in a smaller window:
http://pjgray.ne.mediaone.net/images/avid/smaller_window.jpg
shrir, PJGray, could you please see whether this still happens? We think that a
recent check-in for plug-in content positioning on the Mac should have fixed this.
This is still happening with the 10/26 Mac commercial branch build.
This is definately still happening in the build that we use.  I am not sure of 
the Build ID (commercial branch?) but we download it from here:

http://www.mozilla.org/oji/MRJPlugin.html

I personally am using Netscape 4.73 on MAC OS9.0.4  (its a cube).  However, we 
use many different versions of Netscape here, and they all show the same 
problem with the plugin.
Still happening? Milestone->Future
Target Milestone: M17 → Future
Mac -- Peter, would you give an update on this when you have a chance?
Assignee: av → peterl
Status: ASSIGNED → NEW
petersen or pmac, can you test this and see if it's still "displaying outside
the browser window". It could also be a dup of other familiar pluign painting
problems while scrolling on Mac. Thanks!
Assignee: peterl → peterlubczynski
Keywords: qawanted
Target Milestone: Future → ---
-->WFM

Testcae works great on 2002021108.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.