[mozprofile] Regexp for removing multiline comments from user_js files has unwieldy complexity

RESOLVED FIXED in Firefox 41

Status

Testing
Mozbase
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jgraham, Assigned: jgraham)

Tracking

unspecified
mozilla41
Points:
---

Firefox Tracking Flags

(firefox41 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
As more prefs have been added the running time of this regexp has blown up so it is now tickling the 30s timeout in web-platform-tests.

I propose just removing the feature.
(Assignee)

Comment 1

3 years ago
Created attachment 8617842 [details] [diff] [review]
mozprofile-regexp.diff

https://treeherder.mozilla.org/#/jobs?repo=try&revision=7a21ffb5119d
Attachment #8617842 - Flags: review?(ahalberstadt)
Comment on attachment 8617842 [details] [diff] [review]
mozprofile-regexp.diff

Review of attachment 8617842 [details] [diff] [review]:
-----------------------------------------------------------------

Lgtm! I guess it'll be pretty hard to know if this breaks anyone until they complain about it :/
Attachment #8617842 - Flags: review?(ahalberstadt) → review+
https://hg.mozilla.org/mozilla-central/rev/2182dd1323f4
Assignee: nobody → james
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla41

Updated

3 years ago
Blocks: 1174108

Updated

3 years ago
Duplicate of this bug: 1174108

Updated

3 years ago
No longer blocks: 1174108
Think this might have broken talos on beta, see bug 1187127.
You need to log in before you can comment on or make changes to this bug.