Closed Bug 1173322 Opened 5 years ago Closed 5 years ago

Contact Pane shows birthday -1d for particular birthday dates

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect)

SeaMonkey 2.33 Branch
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1139167

People

(Reporter: gottfried.hausmann, Unassigned, NeedInfo)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:36.0) Gecko/20100101 Firefox/36.0 SeaMonkey/2.33.1
Build ID: 20150321194901

Steps to reproduce:

I wrote 26.7.1951 as date of birth in a address/contact, but 25.7.1951 ist shown, when pointing to this address/contact


Actual results:

25.7.1951 ist shown, when pointing to this address/contact


Expected results:

show the correct date when pointig to the address/contact in the address list / book.
NOT reproducible with EN-US SeaMonkey 2.33.1 (German Language pack)  Gecko/20100101 Build 20150321194901 (Classic Theme) on German WIN7 64bit: I created a new contact with only name, nickname, birthday. Closed address dialog, reopened, birthday still  correct.

@reporter:
You described what you see on your PC with your SeaMonkey, but we need a description how we can reproduce the problem with our SM on our PC.
Please:
a) Contribute a problem related step by step instruction containing every 
   key press and every mouse click how to reproduce your problem due to 
   <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>
   (similar to report in Bug 1139273)
b) Attach screenshots with comments if you believe that that might explain the 
   problem better than a text comment. Best way is to insert your screenshots
   into a OOo or LibreOffice DRAW document and to add comments 
   that explain what you want to show (attach .png or PDF from source document)
c) add information 
c1) concerning your Operating System (Version, Distribution, Language, 
    localization)
c2) concerning your SM localization (UI language, Locale setting)
c3) SM settings that might be related to your problems (May be: complete 
    troubleshooting info from Help)
c4) how you launch SM (Double click on document? console? …)
c5) everything else crossing your mind after you read linked texts
d)  Wether the problem is reproducible for you with other address cards, other 
    birthday dates.
e) Complete list of settings you used due to recommendations of Thunderbird
  (what work) and all differences in settings due to recommendation of SeaMonkey
f) Whether the problem persists in safe mode without add-ons
Flags: needinfo?(gottfried.hausmann)
Attached file screenshot-1.zip
scrennshot which shows the error (date of birth difference).
reproducible with EN-US SeaMonkey 2.33.1 (German Language pack)  Gecko/20100101 Build 20150321194901 (Classic Theme) on German WIN7 64bit: test contadc from comment above shows wrong date in Contact Pane

a) Was still ok  with EN-US SeaMonkey 2.26  (Portable) Gecko/20100101 Firefox/29.0 
   Build 20140428215944 ( Classic Theme) on German WIN7 64bit 
b) Already broken with  2.29.1
c) No longer  reproducible with EN-US SeaMonkey 2.38a1 build by Philip Chee, Gecko/20100101 ,
   Build 20150601233926 (Classic Theme) on German WIN7 64bit
d) I found some DUPs in <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=runnamed&namedcmd=DUPs1173322&list_id=12318832>
e) This one is a DUP of “Bug 1139167 - Some birthdays are off by one day 
   in Thunderbird's addressbook“
f) This problem is notreproducible for all birthday dates, a list with some 
   dates working fin and some dates showning the problem you find in 
   Bug 1122571#c2

@reporter:
Thank you for your bug report! Please feel free to reopen this Bug if you find out that the fix for the other bug does not work for your problem.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Summary: Date of Birth is shown wrong, eg. 26.7.1951 given, 25.7.1951 is shown → Contact Pane shows birthday -1d for particular birthday dates
Duplicate of bug: 1139167
You need to log in before you can comment on or make changes to this bug.