restore libvpx alignment patch

RESOLVED FIXED in Firefox 40

Status

()

Core
Audio/Video
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rillian, Assigned: rillian)

Tracking

Trunk
mozilla41
Points:
---

Firefox Tracking Flags

(firefox38.0.5 unaffected, firefox39 unaffected, firefox40 fixed, firefox41 fixed, firefox-esr38 unaffected)

Details

Attachments

(1 attachment)

David Major says the alignment issue is still reproducible, so we should restore his patch and try to get this upstream.
(Assignee)

Comment 1

2 years ago
Created attachment 8620393 [details] [diff] [review]
Restore libvpx alignment patch
Assignee: nobody → giles
Attachment #8620393 - Flags: review?(kinetik)
(Assignee)

Updated

2 years ago
Component: WebRTC → Video/Audio
Attachment #8620393 - Flags: review?(kinetik) → review+
We'll need to uplift this aggressively I think.  And likely into ESR 38
(Assignee)

Comment 3

2 years ago
Is it as bad as all that? I'm still confused how this one comes and goes.
Keywords: checkin-needed
can we get a try run for this ?
Flags: needinfo?(giles)
Keywords: checkin-needed
(Assignee)

Comment 5

2 years ago
I don't expect any problems. There are no relevant changes since the patch was last applied.
Flags: needinfo?(giles)

Comment 6

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/aca8404dc72c
https://hg.mozilla.org/mozilla-central/rev/aca8404dc72c
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox41: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
Setting status flags (Ralph, please check them).
status-firefox38.0.5: --- → affected
status-firefox39: --- → affected
status-firefox40: --- → affected
status-firefox-esr38: --- → affected
Flags: needinfo?(giles)
(Assignee)

Comment 9

2 years ago
I only removed the alignment patch on April 29th, so release, beta, and esr38 are unaffected. If you're seeing the crash on those branches, it's something else. :/
status-firefox38.0.5: affected → unaffected
status-firefox39: affected → unaffected
status-firefox-esr38: affected → unaffected
Flags: needinfo?(giles)
Comment on attachment 8620393 [details] [diff] [review]
Restore libvpx alignment patch

Approval Request Comment
[Feature/regressing bug #]: bug 1159840
[User impact if declined]: crashes with webrtc.
[Describe test coverage new/current, TreeHerder]: This restores the code we have in beta and release. Landed on nightly.
[Risks and why]: Risk is low. Restores release branch state and change has no side effects that we've seen there.
[String/UUID change made/needed]: None.
Attachment #8620393 - Flags: approval-mozilla-aurora?
(In reply to Ralph Giles (:rillian) from comment #9)
> I only removed the alignment patch on April 29th, so release, beta, and
> esr38 are unaffected. If you're seeing the crash on those branches, it's
> something else. :/

Great!  I wasn't sure...
Comment on attachment 8620393 [details] [diff] [review]
Restore libvpx alignment patch

Fix a crash, taking it.
Attachment #8620393 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/69d21e7b1385
status-firefox40: affected → fixed

Comment 14

2 years ago
https://code.google.com/p/webm/issues/detail?id=1084
You need to log in before you can comment on or make changes to this bug.