Selecting all filters leaves gaps in selection when there are many filters

NEW
Unassigned

Status

()

Toolkit
XUL Widgets
2 years ago
2 years ago

People

(Reporter: edl, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0
Build ID: 20150331220615

Steps to reproduce:

We have over 360 filters. Without going into why, we frequently need to select the entire list of filters in the Message filters dialog. This is done by clicking the first filter in the list to highlight it, scrolling to the bottom of the list, then shift+clicking the last filter in the list to highlight the entire list.


Actual results:

Gaps appear in the selection - groups of one or more filters scattered throughout the list are mysteriously not selected. We must scroll through the list and ctrl+click the skipped filters to add them to the selection


Expected results:

All filters, in between an including the first and last filter in the list, should have been selected after the click - scroll - shift+click sequence.

Comment 1

2 years ago
Are you sure the filters in the middle are not selected and you really have to additionally select them? Or are they selected, just do not appears selected in the display? What happens if you do not select them and run the operation you wish? I think those "unselected" filters will be included too.

Anyway, I can see the visual problem. But I think we have it already reported somewhere.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Whiteboard: [DUPEME]
(Reporter)

Comment 2

2 years ago
Yes, I am certain that they are not selected. We are using a plugin (https://addons.mozilla.org/en-us/thunderbird/addon/quickfilters/) which allows sorting of selected filters in alphabetical order. The filters which fail to get selected do not get sorted - this has been tested. The additional step of shift+click of the unselected filters must be performed in order for them to be sorted.

So this is not just a display/visual issue, it is in fact an actual condition.

Comment 3

2 years ago
OK, then I think it should be a bug in the widget itself.
Component: Filters → XUL Widgets
Product: Thunderbird → Toolkit
Whiteboard: [DUPEME]
Version: 31 → Trunk
(Reporter)

Comment 4

2 years ago
So what would the resolution be?
You need to log in before you can comment on or make changes to this bug.