Jenkins builds are exceeding timeout threshold

RESOLVED DUPLICATE of bug 1172032

Status

Firefox OS
Gaia::UI Tests
RESOLVED DUPLICATE of bug 1172032
3 years ago
3 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
See:
http://jenkins1.qa.scl3.mozilla.com/view/Bitbar/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/96/console
....
05:06:03     hello = self.receive()
05:06:03   File "/var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_transport-0.4-py2.7.egg/marionette_transport/transport.py", line 60, in receive
05:06:03     raise IOError(self.connection_lost_msg)
05:06:03 IOError: Connection to Marionette server is lost. Check gecko.log (desktop firefox) or logcat (b2g) for errors.
05:06:03 
05:06:04 128:34.64 TEST_START: MainThread test_play_ogg_video.py TestPlayOGGVideo.test_play_ogg_video
05:07:42 Build timed out (after 180 minutes). Marking the build as aborted.
05:07:42 FATAL: Caught exception while loading script 'Run Gaia tests'
05:07:42 java.lang.InterruptedException
05:07:42 	at java.lang.Object.wait(Native Method)
05:07:42 	at java.lang.Object.wait(Object.java:503)
05:07:42 	at java.lang.UNIXProcess.waitFor(UNIXProcess.java:210)
05:07:42 	at hudson.Proc$LocalProc.join(Proc.java:319)
05:07:42 	at hudson.Launcher$ProcStarter.join(Launcher.java:388)
05:07:42 	at org.jenkinsci.plugins.managedscripts.ScriptBuildStep.perform(ScriptBuildStep.java:177)
05:07:42 	at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
05:07:42 	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:770)
05:07:42 	at hudson.model.Build$BuildExecution.build(Build.java:199)
05:07:42 	at hudson.model.Build$BuildExecution.doRun(Build.java:160)
05:07:42 	at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:533)
05:07:42 	at hudson.model.Run.execute(Run.java:1759)
05:07:42 	at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
05:07:42 	at hudson.model.ResourceController.execute(ResourceController.java:89)
05:07:42 	at hudson.model.Executor.run(Executor.java:240)
05:07:42 Build step 'Execute managed script' marked build as failure
05:07:42 [Testdroid] - Releasing device session
05:07:42 Archiving artifacts
05:07:42 [htmlpublisher] Archiving HTML reports...
05:07:42 [htmlpublisher] Archiving at BUILD level /var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/workspace/tests/python/gaia-ui-tests/report to /var/lib/jenkins/jobs/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.2.bitbar/builds/2015-06-11_02-05-19/htmlreports/HTML_Report
05:07:42 Recording test results
05:07:42 Found 2 test results
05:07:42 Found failed test junit/results/xml
05:07:43 Found failed test junit/results/xml/_init_
05:07:43 Sending e-mails to: b2g-ci@mozilla.org
05:07:43 Finished: FAILURE

But perhaps this is related to the other result.xml failures in bitbar?
This is a symptom, not the problem. If you examine the console log you'll find:

> 05:07:42 Build timed out (after 180 minutes). Marking the build as aborted.

I recently noticed a lot of builds that were running for days, so I set the jobs to abort after a fixed amount of time. Either this is not enough time, or we've had some sort of unrecoverable failure but Jenkins is still waiting for a response. It looks like we had a crash in this case, which could be related to other crashes we're seeing recently.
Summary: results.xml.<init> failure in Build step 'Execute managed script' marked build as failure on bitbar → Jenkins builds are exceeding timeout threshold
(Reporter)

Comment 2

3 years ago
It seems like this is not an issue anymore, I'll mark it as a duplicate of bug 1172032, since it's probably related.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1172032
You need to log in before you can comment on or make changes to this bug.