Closed Bug 1173859 Opened 4 years ago Closed 4 years ago

Quick consecutive calls to getUserMedia, only last permission dialog is shown

Categories

(Firefox :: Site Permissions, defect)

38 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 861716

People

(Reporter: madis.nomme, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.124 Safari/537.36

Steps to reproduce:

Called getUserMedia 2 times without pressing allow/deny after first call.

Also available at: https://gist.github.com/madis/54cf3afb951af09252c8

Code to reproduce:
navigator.mozGetUserMedia({video: true, audio: false}, function(s) {window.zeVideoOnly = s}, function() {}); navigator.mozGetUserMedia({video: true, audio: true}, function(s) {window.zeVideo = s}, function() {})



Actual results:

First permission dialog is replaced with second. After giving permission from the "top" dialog, the one shown first is lost, so no way to answer.


Expected results:

After pressing allow/deny to the second (the on shown latest), the first one should be shown again.
Component: Untriaged → Notifications and Alerts
Product: Firefox → Toolkit
Flags: needinfo?(florian)
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Component: Notifications and Alerts → Device Permissions
Flags: needinfo?(florian)
Product: Toolkit → Firefox
Resolution: --- → DUPLICATE
Duplicate of bug: 861716
You need to log in before you can comment on or make changes to this bug.