Closed Bug 1173886 Opened 4 years ago Closed 4 years ago

Delay loading of WK resources on initial app launch until needed

Categories

(Firefox for iOS :: Browser, defect)

Other
iOS
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
fxios + ---

People

(Reporter: sleroux, Assigned: sleroux)

Details

We're seeing sluggish start up times when launching the app being caused by initializing WK-related resources like the WKProcessPool and WKWebView. Since we're displaying the Home panels on initial launch, we don't actually need these to be loaded right away. One approach would be to decouple the browser from a tab so we can load the home panel screen without loading a WebView. See https://bugzilla.mozilla.org/show_bug.cgi?id=1163122#c1 for additional discussion on this approach.
tracking-fxios: --- → ?
Assignee: nobody → sleroux
To add some clarification, this situation only occurs when we are restoring with no tabs. In most cases it seems that we always have at least one tab.
I guess that drifts the topic into zombified tabs...
https://hg.mozilla.org/mozilla-central/rev/d3df23a5ad62
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Someone got their bug number wrong. I'll chase that down.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Folks trying to chase that commit down: you're looking for Bug 1173866.
Status: REOPENED → ASSIGNED
Now that we've replaced UIStateRestoration with our own restoration logic, we're not at the mercy of the the system's strange lifecycle logic for when things should be restored so this scenario should only happen in the rare exception that are no tabs to restore since there should always be at least one tab open. See https://bugzilla.mozilla.org/show_bug.cgi?id=1159754 for details.
Status: ASSIGNED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.