overscroll can be very slow

RESOLVED WONTFIX

Status

()

Core
Panning and Zooming
RESOLVED WONTFIX
3 years ago
2 years ago

People

(Reporter: daleharvey, Unassigned)

Tracking

({foxfood, polish})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bzlite][triagr] [foxfoodUX][gfx-noted])

(Reporter)

Description

3 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Draw an L type shape where your finger goes off the screen and the overscroll goes very slowly

its kinda fun but probably should be fixed
Keywords: foxfood
Keywords: dogfood
Component: Gaia::Feedback → General
Flags: needinfo?(fxos.triage.platform)
Flags: needinfo?(fxos.triage.duplicate)
Flags: needinfo?(firefoxos-ux-bugzilla)
Whiteboard: [bzlite] → [bzlite][triagr]
Whiteboard: [bzlite][triagr] → [bzlite][triagr] [foxfoodUX]
Could you please elaborate or perhaps attach a video of the issue? NI again with the info.

Thanks!
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(dale)
(Reporter)

Comment 2

3 years ago
If you go to the homescreen, drag down from the top to the bottom of the screen, then when nearing the bottom middle of the screen move your thumb off the screen to the left or the right in a continuous motion, the overscroll effect presumably takes on the momentum of the current scrolling speed which is extremely slow, so the stretched homescreen will very slowly shrink until it starts to bounce at a normal speed
Flags: needinfo?(dale)
re-adding NI to put back in queue for next week's triage
Flags: needinfo?(firefoxos-ux-bugzilla)
NI Chris Lord - is this a performance issue?

Thanks!
Flags: needinfo?(chrislord.net)
Oops didn't remove flag!
Flags: needinfo?(firefoxos-ux-bugzilla)
(Reporter)

Comment 6

3 years ago
It isnt a performance issue, it seems like the overscroll algorithm should have some minimum velocity or something

Comment 7

3 years ago
This is an apz issue, but I can't reproduce on new homescreen right now, ftr.
Component: General → Panning and Zooming
Flags: needinfo?(chrislord.net)
Product: Firefox OS → Core
You might be running into bug 1143904.
Keywords: polish
Whiteboard: [bzlite][triagr] [foxfoodUX] → [bzlite][triagr] [foxfoodUX][gfx-noted]
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(fxos.triage.platform)
Flags: needinfo?(fxos.triage.duplicate)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.