All users were logged out of Bugzilla on October 13th, 2018

[Flame] Shallow flashing to tinderbox KK central eng builds causes error: No space left on device

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: pcheng, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing])

(Reporter)

Description

3 years ago
Description:
When shallow flashing latest builds from https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/mozilla-central-flame-kk-eng/ , it gives an error saying that the device has run out of space when I try to flash it the second time.

STR:
1) Base the Flame to v18D-1 base image
2) Shallow flash to a latest build from the above link

- Observe the flash is successful and device enters FTU

3) Shallow flash the same build again

Expected: Flashing is successful and enters FTU

Actual: Flashing is unsuccessful. The terminal shows an error saying: "No space left on device".

Repro rate: 10 out of 10 for me.
(Reporter)

Comment 1

3 years ago
This issue doesn't happen on v2.2 (from this link: https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/tinderbox-builds/mozilla-b2g37_v2_2-flame-kk-eng/ )
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [3.0-Daily-Testing]
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
(Reporter)

Updated

3 years ago
QA Contact: pcheng
(Reporter)

Comment 2

3 years ago
mozilla-inbound regression window:

Last Working
Device: Flame
BuildID: 20150603064143
Gaia: 477b5672811ed970a7476fe6f67dba546a302dce
Gecko: 24d30440d9eb
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

First Broken
Device: Flame
BuildID: 20150603072142
Gaia: 477b5672811ed970a7476fe6f67dba546a302dce
Gecko: 91bba46e795a
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Gaia is the same so it's a Gecko issue.

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=24d30440d9eb&tochange=91bba46e795a

From the pushlog, it seems like Bug 1051146 is a possible culprit.
Blocks: 1051146
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Kelly, can you take a look at this please? Looks like the landing for bug 1051146 might be the cause here.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(kdavis)

Comment 4

3 years ago
(In reply to KTucker [:KTucker] from comment #3)
> Kelly, can you take a look at this please? Looks like the landing for bug
> 1051146 might be the cause here.

Sounds likely that Bug 1051146 is the cause. 

Bug 1051146 installs a speech-to-text engine on B2G nightly, and part of this
engine is a statistic model of the English language. This model is on the order
of 20MB.

The question is what to do.

The model installation is behind a flag. So, it can be easily turned on or off,
but then people working on the UI/UX for our voice app will have to compile their
own gecko, which is also not ideal.

This Thursday we, the group working on a speech interface to B2G, have a team
meeting where we can discuss the proper resolution. I'll give an update then.

Comment 5

3 years ago
It looks like we can get this solved through this Bug 1154072 Comment 31,
the partition size will be expanded.
Flags: needinfo?(kdavis)
Flags: needinfo?(nhirata.bugzilla)
QA wanted to see if this still occurs.
Flags: needinfo?(nhirata.bugzilla)
Keywords: qawanted
(Reporter)

Comment 7

3 years ago
We haven't seen this since we moved to v18D nightly v4 base image. Fixed by changing base image and closing bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawanted
Resolution: --- → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.