Firefox breaks printing (and preview) of multipage website after page breaking of FIELDSET element

RESOLVED DUPLICATE of bug 471015

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 471015
3 years ago
3 years ago

People

(Reporter: Andrzej Bator, Unassigned)

Tracking

({testcase})

38 Branch
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPE?)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8621471 [details]
Poziom Kraju.pdf

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

Coding a page which consists of long forms with fields surrounded by FIELDSET elements. Problem occurring only when fieldset is divided between pages.


Actual results:

During printing ALL pages that are after fieldset page break are missing.

This happens only in Firefox, all other browsers i checked (Opera, IE, Chrome, Safari) prints those forms correctly.

Reproducible: Always

This is also confirmed by users of the website.

I have to add that this problem appeared many years ago, since Firefox version 3 or 3.5 and is not solved till now.

This
https://bugzilla.mozilla.org/show_bug.cgi?id=279359 
maybe same bug report but hard to tell as it completely lack of tech details.


Expected results:

Print complete form.

Comment 1

3 years ago
could you attach the test file to the bug, please.
Flags: needinfo?(ab)
Keywords: testcase-wanted
(Reporter)

Comment 2

3 years ago
Created attachment 8621635 [details]
Simple example code
Flags: needinfo?(ab)

Comment 3

3 years ago
Print preview is broken too, anyway it is probably already reported.
Component: Untriaged → Printing: Output
Keywords: testcase-wanted → testcase
Product: Firefox → Core
Summary: Firefox breaks printing of multipage website after page breaking of FIELDSET element → Firefox breaks printing (and preview) of multipage website after page breaking of FIELDSET element
Whiteboard: DUPE?

Comment 4

3 years ago
I found it. Old bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 471015
(Reporter)

Comment 5

3 years ago
So little chance to fix it?
(Reporter)

Comment 7

3 years ago
This explanation made sense when it was FF 3.0 and new releases took few years to come out. I hope You will manage your priorities and finally fix it.
You need to log in before you can comment on or make changes to this bug.