[classic]Use InfoText, not WindowFrame, for tooltip border

RESOLVED WORKSFORME

Status

SeaMonkey
Themes
RESOLVED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Jim Song, Assigned: Joe Hewitt (gone))

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    0.9.7

On Solaris, choose classic theme, then move your mouse 
to the toolbar, you can see the background color of 
the tooltip window is gray instead of yellow. 


Reproducible: Always
Steps to Reproduce:
1.choose classic theme
2.
3.

Actual Results:  Tooltip background color is gray.

Expected Results:  Tooltip background color should be yellow.
(Reporter)

Comment 1

17 years ago
The tooltip color is designed in file 
themes\classic\global\win\popup.css
It is defined as follow:
    background-color      : InfoBackground;

In Theme Modern, it is defined in file
themes\modern\global\popup.css
as follow:
  background-color: #FFFFE7;

So the simplest way to solve this problem is to define it in classic them 
as it in modern theme.
I also trace into the program, and found when using classic theme, 
sInfoBackground is not set to the right value. But I don't know whether it
is needed to modify these c files.



Component: XP Apps → Browser-General
What does your GTK configuration set that system color to?
themes?
Assignee: trudelle → hewitt
Component: Browser-General → Themes
QA Contact: sairuh → pmac
The tooltip you see is painted using the default system colors (e.g., GTK
configs, try changing your GTK theme)

Reporter: Are you sure grey isn't the system's default tooltip color?
(Reporter)

Comment 5

17 years ago
I can see the system infobackground is yellow.
And I never have config the Gtk themes. I am
also wondering why it is all right on Linux, 
but have the wrong color on Solaris.

If you can configure it to the fixed color in
modern theme, why not in Classic?

> I can see the system infobackground is yellow.

Is "system" in this case GNOME or CDE?

> If you can configure it to the fixed color in modern theme, why not in
> Classic?

Because the modern theme uses fixed colors throughout (for both text and 
backgrounds).  Classic uses system colors (for both text and backgrounds) so 
that it blends in with other apps on the system.  That's the whole point of 
Classic and the reason for its existence.  Changing the background to a fixed 
color in Classic would lead to invisible text with some system configurations, 
since the text would be the color of the background.
(Reporter)

Comment 7

17 years ago
I am using CDE.
(Reporter)

Comment 8

17 years ago
Actually, the infobackground is also gray on GNOME desktop (Solaris).
Right.  Mozilla uses the GNOME settings (it has no way to determine which 
desktop you are actually running, so it always uses the GTK settings if it was 
compiled to use GTK).
(Reporter)

Comment 10

17 years ago
Hi, Boris,
Here is two points about this bug:

1) Normally, the user does not care how to configure tooltip color in gtk,
   so I think the blured tooltip is a BUG.

2) On my system, the tooltip border and tootip background have the same
   color with the toolbar background. That's the reason I could not see 
   clearly the tooltip text. 
   So I suggest to change the tooltip border color from WindowFrame ( in
   tooltip style, windowframe is the same as infobackcolor ) to InfoText.
   I test this modification, it really can give the clear tooltip.

(Reporter)

Comment 11

17 years ago
And I can see the tooltip border on Window version.
Resummarizing to cover point 2, which is a reasonable request.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: When Using Classic Theme: tool tip background color is incorrect → [classic]Use InfoText, not WindowFrame, for tooltip border
(Reporter)

Comment 13

17 years ago
Oh, I see the tooltip border HAS been changed to Infotext in the Trunk. 
So, maybe this bug can be closed now ?
Sure thing.  Please reopen if the problem reappears.  :)
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.