fairly random crash signing into ebay (gnome bug #67691 - galeon)

RESOLVED DUPLICATE of bug 171445

Status

Core Graveyard
Embedding: GTK Widget
--
critical
RESOLVED DUPLICATE of bug 171445
17 years ago
6 years ago

People

(Reporter: Yanko Kaneti, Assigned: blizzard)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
galeon version 1.0.2  - mozilla 0.9.7
to quote from http://bugzilla.gnome.org/show_bug.cgi?id=67691 :

I wasn't doing anything weird - I just got this crash signing into
ebay.



Debugging Information:

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[New Thread 1024
(runnable)]
[New Thread 2049 (runnable)]
[New Thread 1026 (runnable)]
[New Thread 2051 (runnable)]
[New Thread 3076 (runnable)]

0x407978c9 in __wait4 () from /lib/libc.so.6
#0  0x407978c9 in __wait4 () from /lib/libc.so.6
#1  0x407f614c in __DTOR_END__ () from /lib/libc.so.6
#2  0x402aa975 in waitpid (pid=3317, stat_loc=0xbfffed50, options=0)
    at wrapsyscall.c:134
#3  0x403697ff in gnome_segv_handle (signum=11) at gnome-init.c:659
#4  0x402a9532 in pthread_sighandler (signo=11, ctx=
      {gs = 0, __gsh = 0, fs = 0, __fsh = 0, es = 43, __esh = 0, ds = 43, __dsh
= 0, edi = 1090152352, esi = 141787568, ebp = 3221221592, esp = 3221221584, ebx
= 1090242784, edx = 4294967212, ecx = 1, eax = 1090096672, trapno = 14, err = 4,
eip = 1088294344, cs = 35, __csh = 0, eflags = 66066, esp_at_signal =
3221221584, ss = 43, __ssh = 0, fpstate = 0xbfffee50, oldmask = 2147483648, cr2
= 4294967224}) at signals.c:96
#5  <signal handler called>
#6  0x40de0dc8 in NSGetModule ()
   from /usr/lib/mozilla/components/libgkcontent.so
#7  0x4002ca62 in EmbedProgress::RequestToURIString ()
   from /usr/lib/libgtkembedmoz.so
#8  0x4002c3b3 in EmbedProgress::OnStateChange ()
   from /usr/lib/libgtkembedmoz.so
#9  0x40c2e7bb in NSGetModule ()
   from /usr/lib/mozilla/components/liburiloader.so
#10 0x40c2dd8a in NSGetModule ()
   from /usr/lib/mozilla/components/liburiloader.so
#11 0x40c2db0f in NSGetModule ()
   from /usr/lib/mozilla/components/liburiloader.so
#12 0x40ab2fdb in NSGetModule () from /usr/lib/mozilla/components/libnecko.so
#13 0x40ab2b99 in NSGetModule () from /usr/lib/mozilla/components/libnecko.so
#14 0x40c2d709 in NSGetModule ()
......
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
(Reporter)

Comment 1

16 years ago
With recent mozillas the bug is still here but in a slightly different backtrace

#5  <signal handler called>
#6  0x40efd4e4 in DummyParserRequest::GetURI ()
   from /usr/lib/mozilla-1.1/components/libgkcontent.so
#7  0x4002cb9f in EmbedProgress::RequestToURIString ()
   from /usr/lib/libgtkembedmoz.so
#8  0x4002c603 in EmbedProgress::OnStateChange ()
   from /usr/lib/libgtkembedmoz.so
#9  0x40d1eb91 in nsDocLoaderImpl::FireOnStateChange ()
   from /usr/lib/mozilla-1.1/components/liburiloader.so
#10 0x40d1e16f in nsDocLoaderImpl::doStartURLLoad ()
   from /usr/lib/mozilla-1.1/components/liburiloader.so
#11 0x40d1dd76 in nsDocLoaderImpl::OnStartRequest ()
   from /usr/lib/mozilla-1.1/components/liburiloader.so
#12 0x40b54885 in nsLoadGroup::AddRequest ()
   from /usr/lib/mozilla-1.1/components/libnecko.so
#13 0x40efd325 in HTMLContentSink::AddDummyParserRequest ()
   from /usr/lib/mozilla-1.1/components/libgkcontent.so
#14 0x40ef6d4f in HTMLContentSink::WillBuildModel ()
   from /usr/lib/mozilla-1.1/components/libgkcontent.so
#15 0x4122b74a in CNavDTD::WillBuildModel ()
   from /usr/lib/mozilla-1.1/components/libhtmlpars.so
#16 0x4123d9b5 in nsParser::WillBuildModel ()
   from /usr/lib/mozilla-1.1/components/libhtmlpars.so
#17 0x4123e4e3 in nsParser::ResumeParse ()
   from /usr/lib/mozilla-1.1/components/libhtmlpars.so
#18 0x4123fed7 in nsParser::OnDataAvailable ()
   from /usr/lib/mozilla-1.1/components/libhtmlpars.so
#19 0x40d1b643 in nsDocumentOpenInfo::OnDataAvailable ()
   from /usr/lib/mozilla-1.1/components/liburiloader.so
#20 0x40b6a743 in nsStreamListenerTee::OnDataAvailable ()
   from /usr/lib/mozilla-1.1/components/libnecko.so
#21 0x40ba031f in nsHttpChannel::OnDataAvailable ()
   from /usr/lib/mozilla-1.1/components/libnecko.so
#22 0x40b69c1a in nsOnDataAvailableEvent::HandleEvent ()
   from /usr/lib/mozilla-1.1/components/libnecko.so
#23 0x40b589a4 in nsARequestObserverEvent::HandlePLEvent ()
   from /usr/lib/mozilla-1.1/components/libnecko.so
#24 0x400dc297 in PL_HandleEvent () from /usr/lib/libxpcom.so
#25 0x400dc1b3 in PL_ProcessPendingEvents () from /usr/lib/libxpcom.so
#26 0x400dd108 in nsEventQueueImpl::ProcessPendingEvents ()
   from /usr/lib/libxpcom.so
#27 0x40be8a83 in event_processor_callback ()
   from /usr/lib/mozilla-1.1/components/libwidget_gtk.so
#28 0x40be87fd in our_gdk_io_invoke ()
   from /usr/lib/mozilla-1.1/components/libwidget_gtk.so
#29 0x4060a873 in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#30 0x4060be99 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#31 0x4060c461 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#32 0x4060c5e9 in g_main_run () from /usr/lib/libglib-1.2.so.0
#33 0x4052ec6c in gtk_main () from /usr/lib/libgtk-1.2.so.0
#34 0x08093655 in main ()
#35 0x407999cb in __libc_start_main (main=0x80933d0 <main>, argc=2, 
    argv=0xbffff7c4, init=0x806dbc4 <_init>, fini=0x80df550 <_fini>, 
    rtld_fini=0x4000aea0 <_dl_fini>, stack_end=0xbffff7bc)
    at ../sysdeps/generic/libc-start.c:92
(Reporter)

Comment 2

16 years ago
Obviously this bug is very much reproducible when mozilla and galeon have been
compiled with gcc 3.2
(Reporter)

Updated

16 years ago
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 171445 ***
Component: Embedding: GTK Widget → Embedding: GTK Widget
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.