No option to change popup windows to full mozilla windows

VERIFIED DUPLICATE of bug 26353

Status

SeaMonkey
UI Design
--
minor
VERIFIED DUPLICATE of bug 26353
16 years ago
13 years ago

People

(Reporter: jg, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011012
BuildID:    2001112516

Many sites use pop windows, either by <a href> style links or by custom
javascript code. Currently there is no direct way to find the location of this
pop up window.

For example go to the URL above. It would be useful to be able to open the page
that pops up when you click "Listen Live /\" at the top of the page.  Right
click -> Open in new window reveals a different URL
http://www.bbc.co.uk/radio1/realaudio/index.html

If there was a right click->"Display in full window" option that would be very
useful, especially for wantinig the check the html src or other html type uses.

In Netscape 4.7 "rightclick->Page info" alows copy and paste of the URL, this is
not available currently in the Mozilla I have now

"The View Page source" item that was on the netscape right click menu is not
availalbe currently, that would be one way of hacking the URL to the popup
window I have used before. It seems to be blocked from popup windows for some
reason I am not sure..

Reproducible: Always
Steps to Reproduce:
1.Go to http://www.bbc.co.uk/radio1/alt/peel_features/peel_festive_fifty.shtml
2.click "Listen Live"
3.Try and work out how to open it in a real window

Actual Results:  Comes up in small window

Expected Results:  It would be useful to have a right click->"Display in full
window" option

Currently there are 2 work arounds I have found.

1) Type the URL again from the Page Info window
2) Edit the HTML of the prevous page and try and find the URL
3) Add a bookmark and then select the bookmark the see in a normal window.

HAPPY NEW YEAR!
The fact that you can't copy from page info is bug 55713 (has a fix attached to 
bug 52730).

Comment 2

16 years ago
->blaker, cc marlon, mpt for possible inclusion in context menus.
Assignee: trudelle → blaker

Comment 3

16 years ago
that would be bug 26353

*** This bug has been marked as a duplicate of 26353 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.