Closed Bug 1174296 Opened 5 years ago Closed 4 years ago

Change add-on name, version and description font sizes to match in-content preferences

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla48
Tracking Status
firefox48 --- verified
firefox49 --- verified
firefox50 --- verified

People

(Reporter: rfeeley, Assigned: Unfocused)

References

Details

(Whiteboard: [qx:spec])

Attachments

(2 files)

Attached image font-size.png
So that add-ons can potentially be harmoniously integrated into in-content preferences, the front styling should start to match.

First stop, add-on name and description font size. See attached.
First reaction was that this makes the add-on names harder to scan, because they're not as visually distinct. But after looking at it a bit more, I don't know that it's a significant issue. Maybe worth thinking about if you haven't already?

I think it would actually help more if we could move the version number somewhere more out of the way... Well, actually, it looks like we've already done that in some other bug? I don't see version numbers there in Nightly now.
(Bug 1161183 removed it)
Version numbers were added in Firefox 4.0b2pre by bug 562052 and later removed in Firefox 41 and ported to Firefox 40 (and of course in the corresponding versions of Thunderbird and SeaMonkey) by bug 1161183. This removal caused complaints among some users, which led to the birth of an add-on to add them back: https://addons.mozilla.org/addon/amversionnumber/
Assignee: nobody → bmcbride
Status: NEW → ASSIGNED
Attached patch Patch v1Splinter Review
Also updated the details view. Lots of stuff I didn't touch that may or may not be candidates for followups (relnotes, notifications, etc etc).
Attachment #8738881 - Flags: review?(dtownsend)
Attachment #8738881 - Flags: review?(dtownsend) → review+
https://hg.mozilla.org/mozilla-central/rev/ca3f8c085a58
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
I managed to reproduce this issue on Firefox 47.0 RC and on Mac OS X 10.11.1.
The issue is no longer reproducible on Firefox 48.0b1, Firefox 49.0a2 (2016-06-14) Firefox 50.0a1 (2016-06-14).
The tests were performed on Windows 10 x64, Mac OS X 10.11.1 and on Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.