Closed Bug 1174330 Opened 4 years ago Closed 4 years ago

Allow the device name to be edited in-line

Categories

(Firefox :: Sync, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 41
Tracking Status
firefox41 --- verified

People

(Reporter: rfeeley, Assigned: eoger)

References

Details

Attachments

(4 files, 1 obsolete file)

Attached image device-name.gif
So that I can avoid accidentally changing my device name, as a Firefox Sync user, I want to be able to explicitly edit the sync device name.
What do you think? Screenshots incoming!
Attached image view.png
Attached image edit.png
Looks amazing! Another 14px of margin top and bottom and it's good to go! Next step will be to handle network errors in the (something that the user has no indication of today).
Updated with the margins!
Attachment #8621924 - Attachment is obsolete: true
Attachment #8622699 - Flags: review?(markh)
Comment on attachment 8622699 [details] [diff] [review]
0001-Bug-1174330-Allow-the-device-name-to-be-edited-in-li.patch

Review of attachment 8622699 [details] [diff] [review]:
-----------------------------------------------------------------

Looks great!
Attachment #8622699 - Flags: review?(markh) → review+
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/e216d138b9df
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
Two minor issues with this landing.

No idea why you put the new strings between one label and its accesskey. Besides that
http://hg.mozilla.org/mozilla-central/diff/e216d138b9df/browser/locales/en-US/chrome/browser/preferences/sync.dtd

> <!ENTITY changeSyncDeviceName.label "Change Device Name...">

This string should use the single Unicode character "…", not "..." (consistency with all the rest of the copy). Since it's just a fix for en-US, no need to use a new string ID.
Flags: needinfo?(edouard.oger)
One more question: are we still using syncDeviceName.label and syncDeviceName.accesskey anywhere else? If not, no sense in keeping them around.
Depends on: 1177873
syncDeviceName.label and syncDeviceName.accesskey are still used by the legacy sync stuff, I think we should keep them around for now.
Flags: needinfo?(edouard.oger)
I have reproduced this bug in Nightly 41.0a1 (2015-06-12) (Build ID:20150612030205) on Windows 10 64bit.

Bug is fixed now on latest Developer edition 41.0a2 (2015-08-10) (Build ID:20150810004008)

UA: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:41.0) Gecko/20100101 Firefox/41.0

[bugday-20150812]
(In reply to Forhad Hossain from comment #12)
> I have reproduced this bug in Nightly 41.0a1 (2015-06-12) (Build
> ID:20150612030205) on Windows 10 64bit.

Thanks very much!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.