No current or upcoming Events in Today Pane

RESOLVED FIXED in 4.0.1

Status

Calendar
Lightning Only
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: post, Assigned: mmecca)

Tracking

Lightning 4.0.0.1
4.0.1

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8621959 [details]
Unbenannt.PNG

The calendar works fine. Only the today pane shows no current or upcoming events. Its is empty

Comment 1

2 years ago
What calendar(s) are you using? Do you see any messages in the error log (ctrl+shift+j)?
(Reporter)

Comment 2

2 years ago
I'm using TB 38.0.1 with Lighning 4.0.0.1.

Zeitstempel: 13.06.2015 11:31:57
Fehler: NS_NOINTERFACE: Component does not have requested interface [calIOperation.isPending]
Quelldatei: chrome://calendar/content/agenda-listbox.js
Zeile: 649
(Reporter)

Comment 3

2 years ago
Zeitstempel: 13.06.2015 11:34:24
Fehler: [Exception... "Component does not have requested interface [calIOperation.isPending]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://calendar/content/calendar-base-view.xml :: addItemsFromCalendar/refreshJob.cancel :: line 489"  data: no]
STACK: addItemsFromCalendar/refreshJob.cancel@chrome://calendar/content/calendar-base-view.xml:489:0
addItemsFromCalendar/refreshJob.execute@chrome://calendar/content/calendar-base-view.xml:506:26
addItemsFromCalendar@chrome://calendar/content/calendar-base-view.xml:547:10
refresh@chrome://calendar/content/calendar-base-view.xml:437:14
onLoad@chrome://calendar/content/calendar-base-view.xml:78:16
notifyFunc@resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Mario/AppData/Roaming/Thunderbird/Profiles/gtcaw4u3.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1225:16
calListenerBag_notify@resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Mario/AppData/Roaming/Thunderbird/Profiles/gtcaw4u3.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1231:8
calObserverBag_notify@resource://calendar/modules/calProviderUtils.jsm:459:15
calCompositeCalendarObserverHelper.prototype.onLoad@file:///C:/Users/Mario/AppData/Roaming/Thunderbird/Profiles/gtcaw4u3.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:44:12
notifyFunc@resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Mario/AppData/Roaming/Thunderbird/Profiles/gtcaw4u3.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1225:16
calListenerBag_notify@resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Mario/AppData/Roaming/Thunderbird/Profiles/gtcaw4u3.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1231:8
calObserverBag_notify@resource://calendar/modules/calProviderUtils.jsm:459:15
calDav_finalizeUpdatedItems@file:///C:/Users/Mario/AppData/Roaming/Thunderbird/Profiles/gtcaw4u3.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calDavCalendar.js:1185:0
mg_onStopRequest@resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Mario/AppData/Roaming/Thunderbird/Profiles/gtcaw4u3.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:786:0

Quelldatei: resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Mario/AppData/Roaming/Thunderbird/Profiles/gtcaw4u3.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Zeile: 1228
(Reporter)

Comment 4

2 years ago
Update... after the 3rd restart of TB the pane is working... Crazy

Comment 5

2 years ago
I was asking not for the software versions you use but for the calendars (rsp. calendar types, CalDAV Google provider, ics, local,...).

Based on the log entry, you have at least one CalDAV calendar. Network calendars (as CalDAV) initially may take some time to build up the cache completely depending on the size of the respective calandar.

Did you upgrade or do you use a fresh installation/profile and set up the calendar newly?
(Reporter)

Comment 6

2 years ago
Sorry,

I'm synchronizing via CalDav with Google Calendar.

I did an upgrade.

Comment 7

2 years ago
Hello,
i can confirm this (it's duplicate to Bug 1168391). After upgrading from TB 31 to TB 38 with Lightning 4.0.0.1 the bug appeard.

Using CalDAV calendars hosted on a Davical server. No problems until upgrading TB.

Workaround with clicking on "expand" of the "headers" (today, next 5 days) in the today pane to show the items work. Also when you add a new reminder directly in the today pane, the items appear, too.

TB 38.0.1 with Lightning 4.0.0.1 on Mac OSX 10.10

Comment 8

2 years ago
Rudolf, do you have the same error messages in the log? What size have your calendars?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

2 years ago
Yes, i get the same error(s). Unfortunately, the error console don't let me copy the content to the clipboard ("Copy" is greyed). The nsresult is identical and the line of error, too. I get pairs of this error message with varying line numbers: 489 and 649.

Comment 10

2 years ago
The calendars are from different size. One contains a lot of entries (may be >1000), all others are less than 100. Disabling the big one didn't change anything.

Comment 11

2 years ago
Just to chime in, I'm experiencing this as well. Yesterday I upgraded to TB38, didn't get prompted for Lightning, so downloaded it myself (aka. no old calendar data in this profile).

I downloaded the "Exchange EWS Provider 3.3.2" from their site as the addons version is broken, and set it up with my workplace's Office365 server. This is working fine in the calendar. 

I then added a WebDAV ics calendar.

Initially, the panes worked fine, but today they're blank. My error console contains:

Timestamp: 21/06/2015 16:52:06
Error: NS_NOINTERFACE: Component does not have requested interface [calIOperation.isPending]
Source File: chrome://calendar/content/agenda-listbox.js
Line: 649

...and...

Timestamp: 21/06/2015 17:01:20
Error: [Exception... "Component does not have requested interface [calIOperation.isPending]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://calendar/content/calendar-base-view.xml :: addItemsFromCalendar/refreshJob.cancel :: line 489"  data: no]
STACK: addItemsFromCalendar/refreshJob.cancel@chrome://calendar/content/calendar-base-view.xml:489:0
addItemsFromCalendar/refreshJob.execute@chrome://calendar/content/calendar-base-view.xml:506:26
addItemsFromCalendar@chrome://calendar/content/calendar-base-view.xml:547:10
refresh@chrome://calendar/content/calendar-base-view.xml:437:14
onLoad@chrome://calendar/content/calendar-base-view.xml:78:16
notifyFunc@resource://calendar/modules/calUtils.jsm -> file:///C:/Home/Jamie/.WinShared/Application%20Data/Thunderbird/Profiles/l1fhgba5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1225:16
calListenerBag_notify@resource://calendar/modules/calUtils.jsm -> file:///C:/Home/Jamie/.WinShared/Application%20Data/Thunderbird/Profiles/l1fhgba5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1231:8
calObserverBag_notify@resource://calendar/modules/calProviderUtils.jsm:459:15
calCompositeCalendarObserverHelper.prototype.onLoad@file:///C:/Home/Jamie/.WinShared/Application%20Data/Thunderbird/Profiles/l1fhgba5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:44:12
notifyFunc@resource://calendar/modules/calUtils.jsm -> file:///C:/Home/Jamie/.WinShared/Application%20Data/Thunderbird/Profiles/l1fhgba5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1225:16
calListenerBag_notify@resource://calendar/modules/calUtils.jsm -> file:///C:/Home/Jamie/.WinShared/Application%20Data/Thunderbird/Profiles/l1fhgba5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1231:8
calObserverBag_notify@resource://calendar/modules/calProviderUtils.jsm:459:15
calICSObserver.prototype.onLoad@file:///C:/Home/Jamie/.WinShared/Application%20Data/Thunderbird/Profiles/l1fhgba5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calICSCalendar.js:822:8
calICSCalendar.prototype.onStreamComplete@file:///C:/Home/Jamie/.WinShared/Application%20Data/Thunderbird/Profiles/l1fhgba5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calICSCalendar.js:223:12

Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Home/Jamie/.WinShared/Application%20Data/Thunderbird/Profiles/l1fhgba5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1228

...I just removed the ics calendar and restarted Thunderbird, synced and my panes are back with the events from my work calendar, so I think the WebDAV is the culprit here...
(Assignee)

Comment 12

2 years ago
Created attachment 8625167 [details] [diff] [review]
Fix v1

Adds a wrapInstance to do a QI on the pending operation.
Assignee: nobody → matthew.mecca
Status: NEW → ASSIGNED
Attachment #8625167 - Flags: review?(philipp)
Attachment #8625167 - Flags: approval-calendar-release?(philipp)
Attachment #8625167 - Flags: approval-calendar-beta?(philipp)
Attachment #8625167 - Flags: approval-calendar-aurora?(philipp)

Updated

2 years ago
Duplicate of this bug: 1168391
Blocks: 1177028
Comment on attachment 8625167 [details] [diff] [review]
Fix v1

Review of attachment 8625167 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM. I wonder why this is breaking now and not before though, I'm not getting this myself on beta.

Neither ics, storage, caldav, gdata nor ews calendars are returning operations on the getItems call, so I'm wondering what is actually causing this. It would be good to figure out exactly which operation is causing this, and see why its not being auto-QI'd to the right interface.
Attachment #8625167 - Flags: review?(philipp)
Attachment #8625167 - Flags: review+
Attachment #8625167 - Flags: approval-calendar-release?(philipp)
Attachment #8625167 - Flags: approval-calendar-release+
Attachment #8625167 - Flags: approval-calendar-beta?(philipp)
Attachment #8625167 - Flags: approval-calendar-beta+
Attachment #8625167 - Flags: approval-calendar-aurora?(philipp)
Attachment #8625167 - Flags: approval-calendar-aurora+

Comment 15

2 years ago
I have set my calendars (CalDAV) to refresh automatically every 60 minutes (some all 30 minutes, but doesn't matter). When the refresh is triggered by the timeout, the items magically appear on the today pane. Seems, the error only occurs on the initial load/start of thunderbird.

Comment 16

2 years ago
I am getting similar results to Rudolf on initial loading of Thunderbird the items show up then disappear on the Today Pane, but after having Thunderbird open for a while the Today Pane shows the events again.  I am still trying to hammer out exactly how long it is until they reappear (some calendars are set to refresh every 15 minutes, others every 30).
  
I can tell you that at least since 38 beta 3 I had this issue.  I initially jumped from Thunderbird 24.2 with Lightning 2.6.4 to Thunderbird 38b3 with Lightning 4.0b3.  

I am going to try Thunderbird 31 with Lightning 3.3.3 to see if I can find exactly when the regression occurred.

Comment 17

2 years ago
No issues for me when running Thunderbird 31.7.0 with Lightning 3.3.3.  Not getting the NS_NOINTERFACE error in the console

Also no issues with Thunderbird 36.0b1 with Lightning 3.8b2 and no NS_NOINTERFACE error.

Likewise no issues or error with Thunderbird 37.0b1 with Lightning 3.9b1.

I can reproduce the issue with Thunderbird 38.0b1 with Lightning 4.0b1.  NS_NOINTERFACE message is showing in the error console and the Today Pane events load then disappear.


So if I wanted to pinpoint the regression it happened as early as Lightning 4.0b1 because 3.9b1 and before work fine.

Error console message from Lightning 4.0b1:

Timestamp: 6/25/2015 11:58:32 AM
Error: NS_NOINTERFACE: Component does not have requested interface [calIOperation.isPending]
Source File: chrome://calendar/content/calendar-base-view.xml
Line: 489

Timestamp: 6/25/2015 11:58:32 AM
Error: [Exception... "Component does not have requested interface [calIOperation.isPending]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://calendar/content/calendar-base-view.xml :: addItemsFromCalendar/refreshJob.cancel :: line 489"  data: no]
STACK: addItemsFromCalendar/refreshJob.cancel@chrome://calendar/content/calendar-base-view.xml:489:0
addItemsFromCalendar/refreshJob.execute@chrome://calendar/content/calendar-base-view.xml:506:26
addItemsFromCalendar@chrome://calendar/content/calendar-base-view.xml:547:10
refresh@chrome://calendar/content/calendar-base-view.xml:437:14
onLoad@chrome://calendar/content/calendar-base-view.xml:78:16
notifyFunc@resource://calendar/modules/calUtils.jsm -> file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1218:16
calListenerBag_notify@resource://calendar/modules/calUtils.jsm -> file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1224:8
calObserverBag_notify@resource://calendar/modules/calProviderUtils.jsm:459:15
calCompositeCalendarObserverHelper.prototype.onLoad@file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:44:12
notifyFunc@resource://calendar/modules/calUtils.jsm -> file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1218:16
calListenerBag_notify@resource://calendar/modules/calUtils.jsm -> file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1224:8
calObserverBag_notify@resource://calendar/modules/calProviderUtils.jsm:459:15
calDav_finalizeUpdatedItems@file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calDavCalendar.js:1185:0
mg_onStopRequest@resource://calendar/modules/calUtils.jsm -> file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:786:0

Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1221

Timestamp: 6/25/2015 11:58:32 AM
Error: NS_NOINTERFACE: Component does not have requested interface [calIOperation.isPending]
Source File: chrome://calendar/content/agenda-listbox.js
Line: 649

Timestamp: 6/25/2015 11:58:32 AM
Error: [Exception... "Component does not have requested interface [calIOperation.isPending]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://calendar/content/agenda-listbox.js :: refreshCalendarQuery/refreshJob.cancel :: line 649"  data: no]
STACK: refreshCalendarQuery/refreshJob.cancel@chrome://calendar/content/agenda-listbox.js:649:0
refreshCalendarQuery/refreshJob.execute@chrome://calendar/content/agenda-listbox.js:678:20
refreshCalendarQuery@chrome://calendar/content/agenda-listbox.js:700:4
agendaListbox.calendarObserver.onLoad@chrome://calendar/content/agenda-listbox.js:926:4
notifyFunc@resource://calendar/modules/calUtils.jsm -> file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1218:16
calListenerBag_notify@resource://calendar/modules/calUtils.jsm -> file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1224:8
calObserverBag_notify@resource://calendar/modules/calProviderUtils.jsm:459:15
calCompositeCalendarObserverHelper.prototype.onLoad@file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:44:12
notifyFunc@resource://calendar/modules/calUtils.jsm -> file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1218:16
calListenerBag_notify@resource://calendar/modules/calUtils.jsm -> file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1224:8
calObserverBag_notify@resource://calendar/modules/calProviderUtils.jsm:459:15
calDav_finalizeUpdatedItems@file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calDavCalendar.js:1185:0
mg_onStopRequest@resource://calendar/modules/calUtils.jsm -> file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js:786:0

Source File: resource://calendar/modules/calUtils.jsm -> file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1221




Also wanted to note that I also see the following messages throughout the error console in Thunderbird 38.0b1 and later:


Timestamp: 6/25/2015 11:58:45 AM
Error: Couldn't find NorthAmerica/Eastern
Source File: file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/distribution/bundles/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calTimezoneService.js
Line: 189


Not sure if this is part of the issue or a separate problem.
(Assignee)

Comment 18

2 years ago
(In reply to Philipp Kewisch [:Fallen] from comment #14)
> Neither ics, storage, caldav, gdata nor ews calendars are returning
> operations on the getItems call, so I'm wondering what is actually causing
> this. It would be good to figure out exactly which operation is causing
> this, and see why its not being auto-QI'd to the right interface.

Oddly the problem was intermittent for me when debugging this, I had to spam the Synchronize button to reliably reproduce it.
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
Pushed to comm-central changeset 7684af65861f
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 4.3
Backported to releases/comm-aurora changeset 96a25c4c2805
Target Milestone: 4.3 → 4.2
Backported to releases/comm-beta changeset 81f91457dfba
Target Milestone: 4.2 → 4.1
Backported to releases/comm-esr38 changeset 90309f6a441e
Target Milestone: 4.1 → 4.0
Target Milestone: 4.0.0.1 → 4.0.1
Duplicate of this bug: 1137413
You need to log in before you can comment on or make changes to this bug.