Closed Bug 1174413 Opened 4 years ago Closed Last year

[enhancement] Sync should include "Search Settings"

Categories

(Firefox :: Sync, enhancement)

38 Branch
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 444284

People

(Reporter: btowntkd, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

Configure custom search settings - change the default search provider, enable/disable various search providers, and configure 'keywords'.


Actual results:

These settings are not included in Firefox sync - they must be reconfigured for every installation across all devices.


Expected results:

The search settings, providers and keywords should all be included in the sync, and should be downloaded onto a new installation.
Priority: -- → P3
Summary: Sync should include "Search Settings" → [enhancement] Sync should include "Search Settings"
Duplicate of this bug: 1214230
Duplicate of this bug: 1250371
Actually, what I think is: all synced data should be visible and editable via sync page so that users can easily choose what to sync in detail instead of tick boxes in about:preferences#sync
Blocks: syncmore
Severity: normal → enhancement
Priority: P3 → --
Duplicate of this bug: 1369943
As now all installed search engines are held in search.json.mozlz4 under profile folder, so is it possible to do this now?
Flags: needinfo?(andy+bugzilla)
Hi there! No, unfortunately, we'd still need to teach Sync how to handle search providers and settings; Sync doesn't directly deal with any files in your profile directory. There's more context in bug 444284, but I think it'll be a while before we get to this, sorry.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Flags: needinfo?(andy+bugzilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 444284
You need to log in before you can comment on or make changes to this bug.