Bookmarks sidebar panel is empty in non-browser windows

VERIFIED FIXED in seamonkey2.39

Status

SeaMonkey
Sidebar
--
minor
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: exalm7659, Assigned: exalm7659)

Tracking

({regression})

SeaMonkey 2.1 Branch
seamonkey2.39
regression

SeaMonkey Tracking Flags

(seamonkey2.35 fixed, seamonkey2.36 fixed, seamonkey2.37 fixed, seamonkey2.38 fixed, seamonkey2.39 fixed)

Details

User Story

http://hg.mozilla.org/comm-central/rev/1e54d458daa6          SeaMonkey 2.39
http://hg.mozilla.org/releases/comm-aurora/rev/b66fc99534fb  SeaMonkey 2.38
http://hg.mozilla.org/releases/comm-beta/rev/7c824ad0d169    SeaMonkey 2.37
http://hg.mozilla.org/releases/comm-release/rev/c47294304732 SeaMonkey 2.36 (which was comm-beta)
http://hg.mozilla.org/releases/comm-release/rev/c83915eb91a0 SeaMonkey 2.35 (SEAMONKEY_2_35_RELEASE_BRANCH)

/me sighs. noticed I forgot to put the bug number in the commit messages.

Attachments

(3 attachments)

(Assignee)

Description

3 years ago
Created attachment 8622077 [details]
Screenshot

Bookmarks sidebar panel is empty in Composer or in Mail Compose.
Error console:
Error: TypeError: window.top.PlacesUIUtils is undefined
Source File: chrome://communicator/content/bookmarks/bm-panel.js
Line: 7

It seems to be just a typo, since PlacesUIUtils get imported in the bm-panel.js itself, but it uses the one from Browser window instead.
(Assignee)

Comment 1

3 years ago
Created attachment 8622078 [details] [diff] [review]
fix-bookmark-sidebar.patch

A possible fix.
(Assignee)

Comment 2

3 years ago
Created attachment 8622079 [details]
Screenshot of the patch

Comment 3

3 years ago
@Reporter:
Please contribute information concerning your OS, MS Version and so on so that other users can find out whether they suffer from the same problem.
Flags: needinfo?(exalm7659)

Comment 4

3 years ago
REPRODUCIBLE with EN-US SeaMonkey 2.33.1 (German Language pack)  Gecko/20100101 Build 20150321194901 (Classic Theme) on German WIN7 64bit:

1. Launch Email client
2. Click Icon 'Compose'
   » Mail Composer (here: Text e-mails) will open
3. <f9> if necessary to show sidebar
4. Click Sidebar Panel 'bookmarks': 
 » is empty (Although in Browser all bookmarks are shown)

Additional info:
a) Already reproducible with 2.29.1, 2.26
b) Was still ok with 2.0
c) Still a problem with EN-US SeaMonkey 2.38a1 build by Philip Chee, Gecko/20100101 , Build 20150601233926 (Classic Theme) on German WIN7 64bit
d) no DUPs found in <https://bugzilla.mozilla.org/buglist.cgi?cmdtype=runnamed&namedcmd=DUPs1174528&list_id=12326886>
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Windows 7
Version: Trunk → SeaMonkey 2.26 Branch
(Assignee)

Comment 5

3 years ago
(In reply to Rainer Bielefeld from comment #3)
> @Reporter:
> Please contribute information concerning your OS, MS Version and so on so
> that other users can find out whether they suffer from the same problem.

Umm, I'm not sure how do I mark that it is reproducible on multiple versions? I was able to reproduce it on 2.33.1 and 2.38a1 and I remember it for being there for much longer time.
Same for platforms: Linux x86, Linux x86_64, Windows XP x86.
Flags: needinfo?(exalm7659)
(Assignee)

Updated

3 years ago
OS: Windows 7 → All
Hardware: Unspecified → All

Comment 6

3 years ago
(In reply to exalm7659 from comment #5)
> Umm, I'm not sure how do I mark that it is reproducible on multiple
> versions? 

The interesting VERSION is the earliest one where the bug can be reproduced, that helps to find the code change with what a regression has been introduced. The tracking flag confirms that the problem still does exist in 2.38.

I hope we will get a review, soon
status-seamonkey2.38: --- → affected
Keywords: regression
(Assignee)

Comment 7

3 years ago
Okay. In this case it's 2.1, the version in which Places-based bookmarks were introduced. Just checked, the bug is there with clean profile.
(Assignee)

Comment 8

3 years ago
Okay. In this case it's 2.1, the version in which Places-based bookmarks were introduced. Just checked, the bug is there with clean profile.
Version: SeaMonkey 2.26 Branch → SeaMonkey 2.1 Branch

Comment 9

3 years ago
Comment on attachment 8622078 [details] [diff] [review]
fix-bookmark-sidebar.patch

You need to request review otherwise nobody will notice this patch.
Plus you need to request review from someone.
Attachment #8622078 - Flags: review?(philip.chee)

Comment 10

3 years ago
Comment on attachment 8622078 [details] [diff] [review]
fix-bookmark-sidebar.patch

Looks reasonable. r=me
Attachment #8622078 - Flags: review?(philip.chee) → review+

Updated

3 years ago
status-seamonkey2.35: --- → affected
status-seamonkey2.36: --- → affected
status-seamonkey2.37: --- → affected
Keywords: checkin-needed
(Assignee)

Comment 11

3 years ago
Umm, even though you have already reviewed it, how do I do it? Sorry, I'm a complete novice in Bugzilla...
status-seamonkey2.35: affected → ---
status-seamonkey2.36: affected → ---
status-seamonkey2.37: affected → ---
Keywords: checkin-needed

Comment 12

3 years ago
(In reply to exalm7659 from comment #11)
> Umm, even though you have already reviewed it, how do I do it? Sorry, I'm a
> complete novice in Bugzilla...

Simply write down the facts in a comment, someone else can handle the dashboard.
(Assignee)

Comment 13

3 years ago
Wait, did I accidentally remove Philip's changes to dashboard by commenting after his comment?
How to revert it?..
Keywords: checkin-needed

Updated

3 years ago
Assignee: nobody → exalm7659
Blocks: 1177041
Status: NEW → ASSIGNED
status-seamonkey2.35: --- → affected
status-seamonkey2.36: --- → affected
status-seamonkey2.37: --- → affected
(Assignee)

Comment 14

3 years ago
Thanks. :)

Comment 15

3 years ago
Comment on attachment 8622078 [details] [diff] [review]
fix-bookmark-sidebar.patch

[Approval Request Comment]
Regression caused by (bug #): migration to Places Bookmarks
User impact if declined: Blank Bookmarks panel in sidebar.
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): no risk. one line bug fix.
String changes made by this patch: none.
Attachment #8622078 - Flags: approval-comm-release?
Attachment #8622078 - Flags: approval-comm-beta?
Attachment #8622078 - Flags: approval-comm-aurora?

Updated

3 years ago
Attachment #8622078 - Flags: approval-comm-beta?
Attachment #8622078 - Flags: approval-comm-beta+
Attachment #8622078 - Flags: approval-comm-aurora?
Attachment #8622078 - Flags: approval-comm-aurora+

Comment 16

3 years ago
http://hg.mozilla.org/comm-central/rev/1e54d458daa6          SeaMonkey 2.39
http://hg.mozilla.org/releases/comm-aurora/rev/b66fc99534fb  SeaMonkey 2.38
http://hg.mozilla.org/releases/comm-beta/rev/7c824ad0d169    SeaMonkey 2.37
http://hg.mozilla.org/releases/comm-release/rev/c47294304732 SeaMonkey 2.36 (which was comm-beta)
Status: ASSIGNED → UNCONFIRMED
status-seamonkey2.36: affected → fixed
status-seamonkey2.37: affected → fixed
status-seamonkey2.38: affected → fixed
status-seamonkey2.39: --- → fixed
Ever confirmed: false
Target Milestone: --- → seamonkey2.39

Comment 17

3 years ago
[needs approval for SeaMonkey 2.35]
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(iann_bugzilla)
Keywords: checkin-needed
Whiteboard: [needs approval for SeaMonkey 2.35]

Updated

3 years ago
Flags: needinfo?(iann_bugzilla)
Attachment #8622078 - Flags: approval-comm-release? → approval-comm-release+

Comment 18

3 years ago
Pushed to SEAMONKEY_2_35_RELEASE_BRANCH on comm-release
http://hg.mozilla.org/releases/comm-release/rev/c83915eb91a0

/me sighs. noticed I forgot to put the bug number in the commit messages.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
status-seamonkey2.35: affected → fixed
Whiteboard: [needs approval for SeaMonkey 2.35]

Updated

3 years ago
User Story: (updated)

Comment 19

2 years ago
VERIFIED with DE SeaMonkey 2.35  (Windows NT 6.1; WOW64; rv:38.0 nightly by Philip Chee)  Gecko/20100101 Build 20150722220804 (Classic Theme) on German WIN7 64bit
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.