Could not fill out form and could not view page source

RESOLVED DUPLICATE of bug 99808

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 99808
16 years ago
16 years ago

People

(Reporter: Manfred Lebek, Assigned: jst)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Could not fill out form and could not view page source.

Comment 1

16 years ago
Reporter : the URL given above (http://66.163.40.8:800/newinfo/) is not
responding to HTTP or ping.  Could you please give more details, and/or a
working testcase
I can reach the site fine, but have no Mozilla here...  Gavin, could you please 
retest?

Comment 3

16 years ago
The page is made in Javascript esentualy, it creates 3 errors and about 15
warning in the Javascrip Console. I can confirm the problem useing 2001123008
Win 98.

Comment 4

16 years ago
Still dead as a doornail for me.  Ping gives 100% packet loss, tracert gives
"destination host unreachable", IE and Moz both time out.  Just doesn't like me,
I guess :-(  Someone else is going have to look at this for now...

Comment 5

16 years ago
I get a JS error twice when loading the page. THe error is:
 
Error: [Exception... "'JavaScript component does not have a method named:
"getInterfaces"' when calling method: [nsIClassInfo::getInterfaces]"  nsresult:
"0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "JS frame
:: http://66.163.40.8:800/newinfo/ws_navigator_page.js :: disable_website ::
line 229"  data: no]
Source File: http://66.163.40.8:800/newinfo/ws_navigator_page.js
Line: 229

Line 229 is:

	if (window.sidebar){
		document.onmousedown=disableselect
		document.onclick=reEnable
	}


I cannot set focus in any of the form elements on this page (20020102 mozilla
windows build). Not sure why. Over to DOM for investigation.
Assignee: asa → jst
Status: UNCONFIRMED → NEW
Component: Browser-General → DOM Level 0
Ever confirmed: true
QA Contact: doronr → desale

Comment 6

16 years ago
Another dup of bug 99808, it's time we fix it.
FWIW, if (window.sidebar) triggers two uncaught exceptions that stop the script
from running. Workaround is to do try { if (window.sidebar) } catch(e) { } or to
use something else than window.sidebar.

*** This bug has been marked as a duplicate of 99808 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.